scheme view stuck with loading animation

Forum Home Forums Runtime Bugs Webstation Bugs scheme view stuck with loading animation

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8581
    Avatar123abc56
    Participant

    After a few click between schemes, the scheme is stuck with loading animation.

    refresh this url will not resume
    xxx.com/scada/View.aspx?viewID=21
    refresh thi url will resume
    xxx.com/scada

    screen cap
    https://drive.google.com/file/d/12usW761By5bdMw2ZGQ4fD4Y1J-GB6wOy/view?usp=sharing

    web log

    2021-03-29 11:39:11 <os-server><www-data><ACT> Request SCADA-Server state
    2021-03-29 11:39:11 <os-server><www-data><ERR> Incorrect SCADA-Server response to state request
    2021-03-29 11:39:11 <os-server><www-data><ACT> Disconnect from SCADA-Server
    2021-03-29 11:39:11 <os-server><www-data><ACT> Connect to SCADA-Server "localhost"
    2021-03-29 11:40:12 <os-server><www-data><ACT> Request SCADA-Server state
    2021-03-29 11:40:12 <os-server><www-data><ERR> Incorrect SCADA-Server response to state request
    2021-03-29 11:40:12 <os-server><www-data><ACT> Disconnect from SCADA-Server
    2021-03-29 11:40:12 <os-server><www-data><ACT> Connect to SCADA-Server "localhost"
    2021-03-29 11:44:05 <os-server><www-data><ACT> Request SCADA-Server state
    2021-03-29 11:47:49 <os-server><www-data><ACT> Request SCADA-Server state
    2021-03-29 11:48:38 <os-server><www-data><ACT> Logout: user. IP address: 127.0.0.1
    2021-03-29 11:48:42 <os-server><www-data><ACT> Request SCADA-Server state
    2021-03-29 11:48:42 <os-server><www-data><ACT> Login: user (Guest). IP address: 127.0.0.1
    2021-03-29 11:48:42 <os-server><www-data><ACT> User information has been updated. IP address: 127.0.0.1. Session: EE06B64156E60F769A17C026
    2021-03-29 11:48:42 <os-server><www-data><ACT> Retrieve components from the installed plugins

    server log

    2021-03-29 11:38:43 <os-server><root><ACT> Disconnect client 127.0.0.1
    2021-03-29 11:39:11 <os-server><root><ACT> Connect to client 127.0.0.1
    2021-03-29 11:39:11 <os-server><root><ACT> The user ScadaWeb is successfully authenticated
    2021-03-29 11:40:11 <os-server><root><ACT> Disconnect client 127.0.0.1
    2021-03-29 11:40:12 <os-server><root><ACT> Connect to client 127.0.0.1
    2021-03-29 11:40:12 <os-server><root><ACT> The user ScadaWeb is successfully authenticated
    2021-03-29 11:48:42 <os-server><root><ACT> Check username and password for user. Result: passed
    #8582
    Avatar123abc56
    Participant

    After brief test, seems only happens when using Firefox. But not 100% sure at the moment.

    #8584
    Avatar123abc56
    Participant

    The issue can be reproduce on the official demo website.
    http://rapidscada.net/scada/Login.aspx
    Use Firefox
    Click “Home scheme” and “Server room scheme” repeat a few times

    screen cap
    https://drive.google.com/file/d/1WrJHLx8mlKARNsTVEk-HH14z4gVD7aad/view?usp=sharing

    #8592
    MikhailMikhail
    Moderator

    Yes, the issue is reproduced. But demo server has very low CPU and RAM.
    What are the parameters of your server? Is it Linux or Windows?

    #8593
    Avatar123abc56
    Participant

    I tried on 3 of my servers, both are Linux
    1. 2 core cpu + 1GB ram (+2gb ssd swap)
    2. 4 core 8th gen i5 + 8GB ram

    The issue appear on both while I am using Firefox from my laptop within 1~3 minute of clicking.
    I tried Chrome, after clicking about 10 minutes, they are still working.

    #8596
    Avatar123abc56
    Participant

    I did another test on my laptop as server
    Windows 10, i5 + 16GB RAM

    Using Firefox both locally and remotely will have this issue.

    There is an error on Firefox when stuck on loading.
    ns_error_not_initialized schemeform.js

    https://drive.google.com/file/d/1I-vHlothMHODKWG7C_nNVINvF_xL367a/view?usp=sharing

    #8606
    MikhailMikhail
    Moderator

    This issue is interesting and unusual. Considering the fact that we anyway will rewrite the entire web application, I suppose, we should check the new web app if this issue still occurs and then fix it.
    dotNET5 doesn’t support WebForms technology that is currently used that’s why we have to create the web app from scratch.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.