Using URL on inteface table

Forum Home Forums Development and Integration Using URL on inteface table

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11732
    JW
    Participant

    Currently, Using URL on inteface table seems only works for absolute URL with one excepthion feature that:
    if the URL is another webservice on the same server, e.g.
    http://localhost:8080/somepath
    Scada will replace the localhost with the lan / internet IP addr depends on the users access, but still like an absolute URL.

    Is it possible to add a relative URL support, to allow easier integration will webservice on the same server?

    ———————-
    Currently, I have 2 case that the current version dose not work.
    Case 1 example.
    scada at 192.168.1.100:80, my another service at 192.168.1.100:8080/somepath, setting on interface table http:///localhost:8080/somepath
    everything works fine on the server itself and the device in the same subnet
    but the scada was integrated into another subnet via NAT 192.168.7.33:20080, for all the device in this subnet, they can only access the scada web, but not my ohter web service from scada.

    Case 2 example.
    scada at localhost:80, my another service at localhost:8080/somepath, they are also a public IP address of the same port.
    daily operation is on localhost, works fine.
    sometimes client will remote access via internet, but our client network firewall seems only allow http on port 80, then my service at 8080 not accessable from scada.
    then I tried to move scada to port 8081. then use nginx at port 80 to do redirect.
    It seems only can work if i use http://the.public.ip.addr:8080/somepath
    It makes all the traffic goes throught the internet, if without internet, my other service can not be access from scada on localhost

    • This topic was modified 1 year, 2 months ago by JW.
    #11735
    Mikhail
    Moderator

    Why the address contains “///” ? Probably, you should change it to http://localhost:8080/somepath to make it work.

    #11736
    JW
    Participant

    sorry the /// in this post was a typo. couldn’t edit it now.
    but in the actual project, the setting was correct.

    In most case the current version works fine.

    But I am looking for solutions for the 2 cases I mentioned.

    #11738
    Mikhail
    Moderator

    You should open a browser console by clicking F12, go to the Network tab, and check what particular web address is requested when connected remotely.

    • This reply was modified 1 year, 2 months ago by Mikhail.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.