The problem of InfluxDB on Scada V6

Forum Home Forums Runtime Bugs Server Bugs The problem of InfluxDB on Scada V6

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10844
    xdwokcn
    Participant

    I try to transfer min Data to InfluxDB ,and set URL like “127.0.0.1:8086” and set the correct token, bucket, orgnazition. but when I restart the server, it report the error like this:

    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][INF] Archive in DAT format: C:\Users\1\Documents\ScadaProjects\Test1\Data\Min\
    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][INF] Archive copy in DAT format: C:\Users\1\Documents\ScadaProjects\Test1\Data\MinCopy\
    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][ERR] Resolver could not find assembly ‘System.Private.Uri.resources, Version=6.0.0.0, Culture=zh-CN, PublicKeyToken=b03f5f7f11d50a3a’
    requested by ‘System.Private.Uri, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’
    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][ERR] Resolver could not find assembly ‘System.Private.Uri.resources, Version=6.0.0.0, Culture=zh-Hans, PublicKeyToken=b03f5f7f11d50a3a’
    requested by ‘System.Private.Uri, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’
    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][ERR] Resolver could not find assembly ‘System.Private.Uri.resources, Version=6.0.0.0, Culture=zh, PublicKeyToken=b03f5f7f11d50a3a’
    requested by ‘System.Private.Uri, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’
    2022-09-20 22:06:59 [DESKTOP-1KFL78H][DESKTOP-1KFL78H$][ERR] Error calling the MakeReady method of the MinCopy archive:
    System.UriFormatException: Invalid URI: The URI scheme is not valid.
    at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind, UriCreationOptions& creationOptions)
    at System.Uri..ctor(String uriString)
    at RestSharp.RestClientOptions..ctor(String baseUrl)
    at InfluxDB.Client.Api.Client.ApiClient..ctor(InfluxDBClientOptions options, LoggingHandler loggingHandler, GzipHandler gzipHandler)
    at InfluxDB.Client.InfluxDBClient..ctor(InfluxDBClientOptions options)
    at InfluxDB.Client.InfluxDBClientFactory.Create(InfluxDBClientOptions options)
    at InfluxDB.Client.InfluxDBClientFactory.Create(String url, Char[] token)
    at Scada.Server.Modules.ModArcInfluxDb.Logic.InfluxHAL.MakeReady()
    at Scada.Server.Engine.ArchiveHolder.MakeReady()

    • This topic was modified 6 days, 15 hours ago by xdwokcn.
    #10854
    Mikhail
    Moderator

    System.Private.Uri is a part of .NET. May be you should install Chinese language pack for .NET.
    You can try downloading the dll from https://www.nuget.org/packages/System.Private.Uri/ , unzip it and copy the requested file into SCADA\ScadaServer\Mod\ModArcInfluxDb.Logic\ directory.

    #10855
    Mikhail
    Moderator

    Could you provide a screenshot of the archive settings?

    #10858
    xdwokcn
    Participant

    Snap of settings

    Now, the influxDB is work well, I think it maybe something wrong with my OS.

    #10859
    xdwokcn
    Participant

    Snap of settings

    Can you see the screenshot of the archive settings?

    #10885
    Mikhail
    Moderator

    Can you see the screenshot of the archive settings?

    No, I can’t.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.