SNMP Device – Value return a comma

Forum Home Forums Communicating with Devices SNMP Device – Value return a comma

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6503
    AvatarErwan
    Participant

    Hello,
    I am a beginner in the use of RapidScada and I have just added my first SNMP line !
    The communication seems to work, but the value returned by the SNMP driver contains several commas which gives me problem.

    https://zupimages.net/up/20/06/r8r9.png
    Is it possible to delete the commas present in the returned result?

    Thank you!

    • This topic was modified 7 months, 2 weeks ago by MikhailMikhail.
    #6505
    MikhailMikhail
    Moderator

    Hello,

    The screenshot is not available. Please upload it again.

    #6507
    AvatarErwan
    Participant

    Hello,

    Please excuse me, I just uploaded my screenshot 🙂

    Commas
    URL : https://image.noelshack.com/fichiers/2020/06/5/1581089654-commas.png

    #6508
    Avatarmanjey73
    Participant

    in appearance, this is like a number, the separators depend on the regional settings of the PC

    If this is string data, it is unlikely to work without changing the driver…. formulas are useless, since you will only have the first 8 bytes

    • This reply was modified 7 months, 2 weeks ago by Avatarmanjey73.
    #6510
    AvatarErwan
    Participant

    The regional settings of my PC are currently set to “FR_fr” which does not use a separator.

    Is it possible that the use of the comma separator is defined at the level of the KpSNMP.dll driver?

    #6511
    Avatarmanjey73
    Participant

    How is the resulting number displayed in the Scada database?

    Yes, you can define regional settings in the code. But I did not study this driver.

    • This reply was modified 7 months, 2 weeks ago by Avatarmanjey73.
    #6513
    AvatarErwan
    Participant

    The number stored in the database contains no commas.

    Unfortunately, with no knowledge in development I would not have the capacity to change the driver.

    #6514
    Avatarmanjey73
    Participant

    Do not pay attention, in SNMP, the variable itself is most likely still text with a label that it is a number. The Communicator displays it probably before sending it to the Scada database. Use the number format in the table to apply the correct multiplier

    #6522
    MikhailMikhail
    Moderator

    Communicator works as system user, so it uses culture settings for “system”. I don’t recommend to change it, it may cause side effects. It’s just displaying that doesn’t affect real data.

    You should open Administrator – Tools – Language and set fr-FR to apply culture settings to Rapid SCADA GUI and web interface. But currently the language pack doesn’t contain French. So settings affect date and number formatting. If you decide to create a translation to French and share it, I will assist you.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.