Runtime Error on Rasbian after upgrade to 5.7.1

Forum Home Forums Runtime Bugs Webstation Bugs Runtime Error on Rasbian after upgrade to 5.7.1

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #6198
    Avatarathes
    Participant

    Dear Mikhail,

    I faced an issue on Raspbian after trying to upgrade from 5.6.x to 5.7.1
    I followed the installation guide, but finally after restart I gave the following error message from the webpage ‘myipaddress’/scada/Login.aspx:

    Application Exception
    Runtime Error
    A runtime error has occurred

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed (for security reasons).

    It looks like the communicator working properly, and collected data is continuously storing in the .dat files, but web interface is unavailable.
    /opt/scada/ScadaAgent/Log
    /opt/scada/ScadaComm/Log
    /opt/scada/ScadaServer/Log
    /opt/scada/ScadaWeb/log
    Logs are error free.

    What should I try?

    #6202
    MikhailMikhail
    Moderator

    May be the web application has no access rights to write error in the log.
    Try providing full write access to /opt/scada/ScadaWeb/log and its content, restart computer, open the web page, and check the log file for additional information.

    #6203
    Avatarathes
    Participant

    Hi Mikhail,

    Thanks for picking this up.

    I changed the owner of /opt/scada/ScadaWeb/log from root:root to www-data:www-data.
    After reboot it changed back to root:root automatically. Looks like this:
    drwxrwxrwt 2 root root 40 dec 17 16:15 log
    No logfiles at all in this folder, but I checked an older archive and there were also no logfiles after half a year of running.

    root@raspberrypi:/opt/scada/ScadaWeb/log# ls -l
    Total 0
    root@raspberrypi:/opt/scada/ScadaWeb/log#

    Symptoms remained the same. Runtime error.

    #6204
    Avatarathes
    Participant

    I changed the web.config file with adding the parameter <customErrors mode=”Off”/>.

    Now I have a more precise error message in the browser:

    System.Web.Compilation.CompilationException
    CS0433: The imported type `Scada.Web.Global’ is defined multiple times

    Description: Error compiling a resource required to service this request. Review your source file and modify it to fix this error.

    Details: CS0433: The imported type `Scada.Web.Global’ is defined multiple times

    Error origin: Compiler

    Error source file: ~/Global.asax
    Exception stack trace:
    at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath, System.CodeDom.Compiler.CompilerParameters options) [0x00312] in <0b08341bcdc54df9ae6180034dd611ae>:0
    at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath) [0x00008] in <0b08341bcdc54df9ae6180034dd611ae>:0
    at System.Web.Compilation.BuildManager.GenerateAssembly (System.Web.Compilation.AssemblyBuilder abuilder, System.Web.Compilation.BuildProviderGroup group, System.Web.VirtualPath vp, System.Boolean debug) [0x00202] in <0b08341bcdc54df9ae6180034dd611ae>:0
    at System.Web.Compilation.BuildManager.BuildInner (System.Web.VirtualPath vp, System.Boolean debug) [0x00106] in <0b08341bcdc54df9ae6180034dd611ae>:0
    Version Information: 6.6.0.161 (tarball Tue Dec 10 11:12:19 UTC 2019); ASP.NET Version: 4.0.30319.42000

    #6215
    MikhailMikhail
    Moderator

    If you activated RAM drive as written in the installation manual, log files are stored in RAM and don’t exist after reboot.

    #6216
    MikhailMikhail
    Moderator

    Try searching for Global.asax in the ScadaWeb folder. There must be only 1 such file.
    May be some old DLLs were not deleted during upgrade. Delete all DLLs in ScadaWeb/bin folder and copy them again.

    #6217
    Avatarathes
    Participant

    You felt absolutely right. After deleting and copying DLLs it working fine.
    I copied the whole 5.6 system on file level, working perfectly.

    I need your advice:
    1.) How to upgrade on Raspbian to 5.7.1 to not screw up the system
    2.) How to migrate config & all from Windows 5.7.1
    3.) How to register on Linux the ModAutoControl

    Should I open one-by-one a thread or can you answer here?

    Kind regards,
    Attila

    #6220
    MikhailMikhail
    Moderator

    1) Please provide the details of the question.
    2) Does your project currently work on Windows and you need to upload the project to Linux? Is the project upgraded to 5.7.1?
    3) I suggest configuring on Windows and then upload the project to Linux. To get a computer code, find it in the log of the module.

    #6221
    Avatarathes
    Participant

    1.) I have now a working Linux 5.6 installation. I want to upgrade to 5.7.1, but did not find any documentation how to do that (I don’t want to reinstall the whole Linux and follow the 5.7.1 Linux installation guide – that is really time consuming) — Is there any simple way to upgrade on Linux from 5.6 to 5.7.1?

    2.) Yes, I installed on Windows 5.7.1 and I migrated successfully my project. It working perfectly on Windows. I want to move (after point (1) ) to Linux. How to move? I found instructions only for 5.6 win->Linux, but the structure changed in 5.7. I don’t want to create more problems for me 🙂

    3.) Thanks, will try.

    #6230
    MikhailMikhail
    Moderator

    1) Standard way:
    Uninstall Rapid SCADA according to uninstall.txt and then install the new version.
    However you can try to copy new files overwriting the existing. Don’t forget to register the Agent daemon, it’s important.

    2) It’s easier than earlier. Click the Deployment profile button. Create a new profile, specify your Linux machine in the profile. Upload the project to Linux from Windows computer.

    #6231
    Avatarathes
    Participant

    1) Worked fine, thank you.
    2) Worked also fine, but it transferred with the Server Common Parameters the Windows default folder configuration, which is obviously not working on Linux. After edeiting this it is fine again.

    Big thank you for your kind support.

    #6232
    MikhailMikhail
    Moderator

    Windows default folder configuration, which is obviously not working on Linux. After edeiting this it is fine again.

    That’s true.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.