Remote Communicator Error

Forum Home Forums Runtime Bugs Communicator Bugs Remote Communicator Error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12016
    TroyV23
    Participant

    I setup a test RapidScada environment on one machine to make sure my modbus configuration was correct, and everything worked perfectly. Now I am trying to separate the Server from communicator, and run them on 2 different computers.

    Computer 1: RapidScada Server, Webstation,
    Computer 2: Communicator

    When I run communicator on Computer 2, I get an error: saying no endpoint listening at 192.XXX.XXX.XXX:100000/ScadaAgent/ScadaAgentSvc/

    There is a firewall between the machines, and have opened ports 10000 and 100002.

    I have confirmed Agent running on both machines.

    Does this arrangement require the RapidGate module? (I don’t have it installed)

    #12017
    manjey73
    Participant

    Not required. You have a PC with a Communicator should be in a separate instance, in which the server address should be specified in the Communicator settings – the 1st PC

    #12019
    Mikhail
    Moderator

    In what moment did you get that error?
    You should install Agent on computer 2 to be able to upload configuration to it using the Administrator app.

    #12023
    TroyV23
    Participant

    I have Agent installed in both places and it is confirmed to be running in task manager. Is there any other configuration I may be missing? The error appears as soon as I try and upload configuration. It is never able to run communicator.

    Not required. You have a PC with a Communicator should be in a separate instance, in which the server address should be specified in the Communicator settings – the 1st PC

    I have defined the server address in Communicator, does the server need to know the address of the communicator as well?

    • This reply was modified 1 week, 3 days ago by TroyV23.
    #12032
    Mikhail
    Moderator

    does the server need to know the address of the communicator as well?

    No.
    Make sure that you try to upload configuration to the proper instance.
    Also try to connect to the remote Agent by a utility, like telnet using IP and port 10002.
    Check the Agent connection in the instance profile. Port should be 10002.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.