Problem with WebStation

Forum Home Forums Installation Issues Problem with WebStation

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #12488
    rapidscada_sii
    Participant

    Hello,
    I followed this https://rapidscada.net/doc/content/latest/en/installation-and-run/manual-installation.html to install Rapid SCADA and after managing my way to install everything, it seems that I still have a problem with my Webstation. All the dll are included and the configuration seems okay. The server runs on IIS on localhost/scada. So I try to access my login page, but it says “Please correct the following errors: The application is not ready. Try again later.”. So I checked my logs and here they are:

    2023-04-25 16:35:11 [FRIDF-L01064][.NET v4.5][ACT] Webstation 6.1.0.0 started
    2023-04-25 16:35:11 [FRIDF-L01064][.NET v4.5][ACT] Storage FileStorage 6.1.0.0 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\FileStorage.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgChart 6.0.0.1 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\PlgChart.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgMain 6.0.1.0 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\PlgMain.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgScheme 6.0.0.0 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\PlgScheme.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgSchBasicComp 6.0.0.1 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\PlgSchBasicComp.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgWebPage 6.0.0.0 loaded from file C:\SCADA\ScadaWeb\ScadaWeb\ScadaWeb\bin\Release\net6.0\publish\PlgWebPage.dll
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgScheme: Retrieve scheme components from the installed plugins
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Plugin PlgScheme: Added components from the PlgSchBasicComp plugin
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ACT] Receive the configuration database
    2023-04-25 16:35:12 [FRIDF-L01064][.NET v4.5][ERR] Error checking server connection:
    Incorrect format of data received from the server: data length is too big
    

    The lasts 2 lines are repeating as long as the server is running. I guess it could be a problem somewhere in my ScadaWebConfig.xml. So I checked and I have those lines for ConnectionOptions:
    <ConnectionOptions>
    <Name>Default Connection</Name>
    <Host>localhost</Host>
    <Port>80</Port>
    <Username>****</Username>

    </ConnectionOptions>

    I tried to change localhost to localhost/scada and to http://localhost/scada. But both of those tries gave me another error in the logs : “Unknown host”.

    Do you have any idea of where to search or what to do to correct this error ?

    • This topic was modified 10 months ago by Mikhail.
    • This topic was modified 10 months ago by Mikhail.
    #12491
    Mikhail
    Moderator

    Hello,

    Webstation v6 uses .NET6. So an application pool, named “.NET v4.5” is invalid.
    The Server service listens to the port 10000, not 80.

    #12504
    rapidscada_sii
    Participant

    Thanks, it works, but I discovered I had issues with my services when I fixed this. After putting every missing file where it belong, it seems that I still have a problem.
    Here are lines of the WebServer logs:
    2023-04-26 14:14:10 [FRIDF-L01064][FRIDF-L01064$][ERR] Authentication failed for user ScadaWeb: Invalid username or password
    2023-04-26 14:14:12 [FRIDF-L01064][FRIDF-L01064$][ERR] Authentication failed for user ScadaComm: Invalid username or password
    So I downloaded the configuration to the Administrator app and it seems that the password configured are correct fot those two users according to their Configuration files. Do you have any ideas why it would fail there ? (I tried to change passwords in the Administrator and updload it in the Server but the operation failed)

    #12509
    Mikhail
    Moderator

    Did you set passwords by clicking the Set Password button in the Users table in Administrator?
    Did you also change passwords in Webstation and Communicator app settings?

    #12516
    rapidscada_sii
    Participant

    I checked and everything seemed alright, also it stopped doing this error. Now I have this error log in the Webstation:

    2023-04-27 15:47:00 [FRIDF-L01064][.NET v6][ERR] Error loading configuration:
    Padding is invalid and cannot be removed.
    2023-04-27 15:47:00 [FRIDF-L01064][.NET v6][ACT] Receive the configuration database
    2023-04-27 15:47:02 [FRIDF-L01064][.NET v6][ERR] Error checking server connection:
    Server and client secret keys do not match.

    This error in ScadaComm:

    2023-04-27 16:14:19 [FRIDF-L01064][FRIDF-L01064$][ERR] Error loading configuration:
    Padding is invalid and cannot be removed.
    2023-04-27 16:14:19 [FRIDF-L01064][FRIDF-L01064$][ERR] Normal execution is impossible
    

    And this error in ScadaServer:

    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ERR] Archive Cur not found in the configuration database
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ERR] Archive Min not found in the configuration database
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ERR] Archive Hour not found in the configuration database
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ERR] Archive Events not found in the configuration database
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ACT] Start listener on port 10000
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][INF] Archive in DAT format: C:\SCADA\ScadaServer\ScadaServer\ScadaServerWkr\bin\Release\Archive
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][INF] Archive copy in DAT format: C:\SCADA\ScadaServer\ScadaServer\ScadaServerWkr\bin\Release\ArchiveCopy
    2023-04-27 16:14:22 [FRIDF-L01064][FRIDF-L01064$][ERR] Unable to read current data

    And the secret keys are the same in every config files.

    #12520
    Mikhail
    Moderator

    Probably, secret keys have invalid format. Generate new secret keys by opening Server – General Options – Listener Options – Generate button

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.