Error state on device

Forum Home Forums Communicating with Devices Modbus Error state on device

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #7017
    Avatarabedi
    Participant

    Hello Mikhail,

    I want to read modbus values from a plc using kpmodbus through LAN port.
    I can ping the plc ip from computer.
    In rapidscada:
    a)communication channel type is TCP client, tcp port:502.
    b)device call number is set to the computer ip.
    c)channel is created.
    d) line state is running.

    but: device state is: error.

    How can I solve this issue?
    Thanks a lot for help.

    #7018
    MikhailMikhail
    Moderator

    Hello,

    Please provide a part of communication line log.

    #7019
    Avatarabedi
    Participant

    2020-07-15 09:16:09 Establish a TCP connection with 172.27.1.210:502
    Error establishing TCP connection: No connection could be made because the target machine actively refused it 172.27.1.210:502

    2020-07-15 09:16:10 Unable to communicate with Device 1 “wp” because connection is not established

    2020-07-15 09:16:11 Attempt to establish TCP connection can not be earlier than 5 seconds after the previous.

    2020-07-15 09:16:11 Unable to communicate with Device 1 “wp” because connection is not established

    2020-07-15 09:16:11 Attempt to establish TCP connection can not be earlier than 5 seconds after the previous.

    2020-07-15 09:16:11 Unable to communicate with Device 1 “wp” because connection is not established

    2020-07-15 09:16:11 Attempt to establish TCP connection can not be earlier than 5 seconds after the previous.

    explanation: server ip: 172.27.1.210
    cpu LAN port ip: 172.27.1.211
    Thanks

    #7022
    MikhailMikhail
    Moderator

    Error establishing TCP connection: No connection could be made because the target machine actively refused it 172.27.1.210:502

    This message means that the PLC is not available by the IP 172.27.1.210 and port 502.
    You should check the PLC.

    #7028
    Avatarabedi
    Participant

    Thanks for the reply. Do you have any idea that how I can check the PLC? there is no special setting in it. Or shall I change the port? or sth else?

    Thanks again.

    #7029
    Avatarabedi
    Participant

    I tried to check the settings.
    The new communication line log:

    2020-07-16 14:07:56 Establish a TCP connection with 172.27.1.211:502

    2020-07-16 14:07:56 Communication session with the Device 1 “wp”, type: KpModbus, address: 2, call number: 172.27.1.211
    Request element group “g1”
    Send (12): 00 55 00 00 00 06 02 03 00 00 00 01
    2020-07-16 14:07:56 Error communicating with Device 1 “wp”: Error reading data: Timeout can be only be set to ‘System.Threading.Timeout.Infinite’ or a value > 0.
    Parameter name: value

    2020-07-16 14:07:56 Disconnect from 172.27.1.211

    #7031
    Avatarhicode
    Participant

    hi,
    are you sur that your device adress is good ? i see “2” for you, have you try with 1 ?

    #7033
    MikhailMikhail
    Moderator

    Timeout can be only be set to ‘System.Threading.Timeout.Infinite’ or a value > 0.

    Please make a screenshot of the device properties in Communicator.

    #7041
    Avatarabedi
    Participant

    Thanks:
    The screen shot image link:
    https://1drv.ms/u/s!ArUszYM3qWAukCmmsWVLtkTl311D

    #7043
    MikhailMikhail
    Moderator

    Sorry, I mean:
    Open Line 2 Parameters – Request Sequence, select the device 1 and then make a screenshot.

    #7044
    Avatarabedi
    Participant
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.