config fie upload

Forum Home Forums Runtime Bugs config fie upload

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #11973
    Zeus
    Participant

    Hi,
    I installed v6 in centos7.
    When i upload project the xml files could not be written into the floader.
    I chomed -R 777 all the floader and it do not work.
    I also tried install v6 in ubuntu 20.04 and it works well

    • This topic was modified 10 months, 2 weeks ago by Mikhail.
    #11976
    Mikhail
    Moderator

    Hello,
    What error do you get? Could you provide a log?
    Could you make a screenshot of the file and directory permissions and owner?

    #11981
    Zeus
    Participant

    Hi,
    I did not get any error in log file.
    I test it in a new ubuntu 20.04.
    It could not override the old config files in the config directory.
    the user and group is both root and the permissions is 777

    #11983
    Mikhail
    Moderator

    Hi,
    If you delete the existing configuration files, is possible to upload new configuration?

    #11991
    Zeus
    Participant

    Hi,
    I tried it and it do not work. there won’t be new file. The directory is empty

    #11993
    Mikhail
    Moderator

    Hi,
    Weird. What is written in Agent settings and log?

    #11998
    Zeus
    Participant

    Hi,
    There is nothing special in log fie
    Config file is below

    <ScadaAgentConfig>
    <ListenerOptions>
    <Port>10002</Port>
    <Timeout>10000</Timeout>
    <SecretKey>0E063D581B1DB27B8E984993DED65CE99284A706756C706C7F3B12C44BD55D4D</SecretKey>
    </ListenerOptions>
    <ReverseConnection enabled=”false”>
    <Name>Reverse Connection</Name>
    <Host>localhost</Host>
    <Port>10002</Port>
    <Username>ScadaAgent</Username>
    <Password>B9D0F030265751578B00E9801C69320C</Password>
    <Instance>Default</Instance>
    <Timeout>10000</Timeout>
    <SecretKey>0E063D581B1DB27B8E984993DED65CE99284A706756C706C7F3B12C44BD55D4D</SecretKey>
    </ReverseConnection>
    <Instances>
    <Instance active=”true” name=”Default”>
    <ProxyMode>false</ProxyMode>
    <Directory>/data/scada/</Directory>
    <AdminUser>
    <Username>ScadaAdmin</Username>
    <Password>B9D0F030265751578B00E9801C69320C</Password>
    </AdminUser>
    </Instance>
    <Instance active=”false” name=”Remote Site”>
    <ProxyMode>true</ProxyMode>
    <AdminUser>
    <Username>ScadaAdmin</Username>
    <Password>B9D0F030265751578B00E9801C69320C</Password>
    </AdminUser>
    <AgentUser>
    <Username>ScadaAgent</Username>
    <Password>B9D0F030265751578B00E9801C69320C</Password>
    </AgentUser>
    </Instance>
    </Instances>
    </ScadaAgentConfig>

    #11999
    Zeus
    Participant

    Hi,
    I use ExtDepPostgreSql to storage config.
    So the config files won’t written into the directory.
    The config info in directory and sql are different.
    The server and comm start up with the config in file but not sql.
    How to config it to make it right?

    #12002
    Mikhail
    Moderator

    Hi,
    Open Config/ScadaInstanceConfig.xml for editing. Set ActiveStorage to PostgreSqlStorage, and restart Rapid SCADA services.

    #12003
    Zeus
    Participant

    Hi,
    It works excellent

    #12007
    Mikhail
    Moderator

    🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.