Users, roles, rights

Forum Home Forums Uncategorized Issues Users, roles, rights

Tagged: , ,

This topic contains 13 replies, has 3 voices, and was last updated by Mikhail Mikhail 3 months, 3 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1948

    Joao
    Participant

    Hello

    I tryed adding a new Role called “Teste” as number 16, i whent to Users and created the user “joao” as number 15, i whent to right pages and i added the all my pages to it, put the Teste on it and i clicked on the view checkbox.
    Passed to server restarted both server and comunication and i whent to page and tryed logging. It opens the page in blank and say “The requested view does not exist or you have insufficient rights to access it.”

    screen shots:

    View post on imgur.com

    View post on imgur.com

    View post on imgur.com

    View post on imgur.com

    Thanks

    #1950
    Mikhail
    Mikhail
    Moderator

    Hello,
    In the 1st image the user joao has the Administrator role. You don’t use your new role Teste for any user.

    Please test, is your table view or scheme successfully opened by admin user or not?

    #1953

    Joao
    Participant

    If I open it as adm it works, but when i changed the role to Test said “The requested view does not exist or you have insufficient rights to access it.” again.

    #1954
    Mikhail
    Mikhail
    Moderator

    You have to add a new record to the Rights table that contains “Servers\” interface object and “Teste” role.

    #1955

    Joao
    Participant

    Works, Thanks!

    #4260
    ngiussani
    ngiussani
    Participant

    Hi Mikhail,

    I had the issues mentioned by Joao en earlier in this post. With the information on these posts, I was able to solve part of the problem I’m experiencing.

    I’m now left with only one issue, that is don’t showing a view to a certain role, which appears to have no effect, as I tried both not adding the view to the role and adding the view leaving both checkboxes unticked. In either case, the view is displayed.

    Am I doing something wrong? Or is this a known issue?

    #4264
    Mikhail
    Mikhail
    Moderator

    Hi,

    Could you provide screenshots of the settings and of the web app?

    #4279
    ngiussani
    ngiussani
    Participant

    Hi Mikhail,

    I forgot to check “Notyfy me…” and didn’t realize you replied.

    Here they go:

    0r6nFY.jpg
    Image 01
    0r6h8O.jpg
    Image 02
    0r68BZ.jpg
    Image 03
    0r6YCn.jpg
    Image 04
    0r6MGJ.jpg
    Image 05
    0r6ogj.jpg
    Image 06

    • This reply was modified 3 months, 4 weeks ago by ngiussani ngiussani.
    • This reply was modified 3 months, 4 weeks ago by ngiussani ngiussani.
    • This reply was modified 3 months, 4 weeks ago by ngiussani ngiussani.
    #4283
    ngiussani
    ngiussani
    Participant

    I forgot to mention, in the previous case, I’m trying to hide the Cfg View from guest user. In the screenshots you can see, as a last attempt, I didn’t even add it to the Rights, and even then, it’s still displayed.

    Thanks again.

    #4286
    Mikhail
    Mikhail
    Moderator

    This is not necessary to add admin and guest to the Rights table. These roles are standard.

    The screenshots are clear. I didn’t catch what goes wrong? ))

    #4287
    ngiussani
    ngiussani
    Participant

    I don’t want the “DataCenterVmsCfg.sch” to be shown in the Guest Role. I don’t care if I can restric the “Control”. I don’t want the user with that role to even see the screen, but yet it is still shown. I don’t know what the “View” does, if it isn’t that.

    I hope I’m clear enough, but If you need me to elaborate, please let me know anything you need to understand my issue.

    Thanks!

    #4299
    Mikhail
    Mikhail
    Moderator

    Users of the Guest role can view all. If you don’t want it, create your own custom role and apply it to the user named “guest”.

    #4300
    ngiussani
    ngiussani
    Participant

    Mikhail,

    Ok. That explains everything. I didn’t know that, but is good to know.

    Once again, thanks for taking the time to answer every question I/we ask. You have developed a great tool and a very poweful one.

    #4304
    Mikhail
    Mikhail
    Moderator

    Thank you. Be free to ask 🙂

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.