RapidGate v5.1.1.0 doesn’t work

Forum Home Forums Installation Issues RapidGate v5.1.1.0 doesn’t work

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8162
    AvatarSergei
    Participant

    I have problems getting RapidGate module to work. After following installation directions, the updated v5.1.1.0 refuses to run appropriately and there’s no Computer Code displayed.

    ScadaServer log shows as follows:

    2021-01-26 12:12:07 <PVELERO-PC><SYSTEM><EXC> Error executing actions on server start in module ModRapidGate: El valor no puede ser nulo.
    Nombre del parĂ¡metro: format
    2021-01-26 12:12:08 <PVELERO-PC><SYSTEM><ACT> Current data are loaded
    2021-01-26 12:12:08 <PVELERO-PC><SYSTEM><ACT> Connect to client 127.0.0.1
    2021-01-26 12:12:08 <PVELERO-PC><SYSTEM><ACT> The user ScadaComm is successfully authenticated
    2021-01-26 12:14:04 <PVELERO-PC><SYSTEM><ACT> Connection listener is stopped
    2021-01-26 12:14:04 <PVELERO-PC><SYSTEM><EXC> Error executing actions on server stop in module ModRapidGate: Referencia a objeto no establecida como instancia de un objeto.

    Also, RapidGate module log shows no activity:

    2021-01-26 12:02:11 Start ModRapidGate module
    2021-01-26 12:03:33 Stop gates
    ——————————————————————————–
    2021-01-26 12:03:37 Start ModRapidGate module
    2021-01-26 12:03:40 Stop gates
    ——————————————————————————–
    2021-01-26 12:03:43 Start ModRapidGate module
    2021-01-26 12:03:46 Stop gates
    ——————————————————————————–
    2021-01-26 12:03:50 Start ModRapidGate module
    2021-01-26 12:04:31 Stop gates

    However, problem was solved (at least to this point) with the installation of RapidGate v5.1.0.0, which doesn’t have a configuration GUI but correctly displays the Computer code and shows running activity in the log.

    I have installed former RapidGate versions before on several RapidScada instances without issues.

    Thanks in advance for any insight on this issue.

    • This topic was modified 4 months, 2 weeks ago by AvatarSergei.
    #8172
    AvatarSergei
    Participant

    Tried on another server (Windows Server 2019) to no avail.

    Scada Server v5.1.4.0
    RapidGate v5.1.1.0

    ScadaServer.log

    ——————————————————————————–
    2021-01-26 19:16:18 <EC2AMAZ-4OFICL4><SYSTEM><ACT> ScadaServerService 5.1.4.0 is started
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Module is loaded from the file C:\SCADA\ScadaServer\Mod\ModDBExport.dll
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Module is loaded from the file C:\SCADA\ScadaServer\Mod\ModAutoControl.dll
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Module is loaded from the file C:\SCADA\ScadaServer\Mod\ModRapidGate.dll
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Check the existence of the data directories is completed successfully
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Check the existence of the configuration database files is completed successfully
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ERR> No active input channels in the configuration database
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Ouput channels are read from the configuration database
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Users are read from the configuration database
    2021-01-26 19:16:19 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Formulas are read from the configuration database
    2021-01-26 19:16:21 <EC2AMAZ-4OFICL4><SYSTEM><ACT> The formulas source code has been compiled
    2021-01-26 19:16:21 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Connection listener is started
    2021-01-26 19:16:21 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Start server
    2021-01-26 19:16:22 <EC2AMAZ-4OFICL4><SYSTEM><EXC> Error executing actions on server start in module ModRapidGate: Value cannot be null.
    Parameter name: format

    2021-01-26 19:16:22 <EC2AMAZ-4OFICL4><SYSTEM><ACT> Current data are loaded

    • This reply was modified 4 months, 2 weeks ago by AvatarSergei.
    #8174
    AvatarSergei
    Participant

    Update:

    Got this error dialogue after trying to ‘Save’ the options in the RapidGate settings GUI.

    RapidGate 5.1.1.0 error

    • This reply was modified 4 months, 2 weeks ago by AvatarSergei.
    #8183
    MikhailMikhail
    Moderator

    Rapid Gate 5.1.1.0 requires Server 5.1.4.1. You should update Rapid SCADA to v5.8.2.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.