OPC UA Driver

Forum Home Forums Uncategorized Issues OPC UA Driver

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5966
    Mikhail
    Moderator

    Alpha version of OPC UA driver released. Download link.

    Currently, the driver does not have a user interface and is configured by editing the configuration file. An example project is contained in the ZIP archive.

    If in the process of using you have questions or suggestions, write to this topic.

    #5968
    kumajaya
    Participant

    It’s works! But missing BouncyCastle.Crypto.dll 1.8.4 in your package.

    #5972
    Mikhail
    Moderator

    Thank you for checking. I added BouncyCastle.Crypto.dll to the ZIP file.
    I also tested the driver on Linux. It works but requires an extra step in configuring. If needed, I will describe here.

    #5980
    Mikhail
    Moderator

    The driver user interface is implemented.

    #9554
    josef.novotny
    Participant

    Hi i try added new OPC UA device.
    Server browse connect OK to new OPC UA device with this security options…
    Security mode – None
    Security policy – None
    Authentication mode – Username and password
    Username – myusername
    Password – mypassword

    Save configuration, upload config to server, but in line state is Error.
    I check again security options in device properties.
    Username is lost.
    Why?

    Thanks for your reply, Josef

    #9558
    Mikhail
    Moderator

    Hi,
    What is the driver version?
    Please provide screenshots of the settings and the error message, and communication line log.

    #9559
    josef.novotny
    Participant

    Hy, driver version is…
    KpOpcUa.dll… 5.0.0.0
    Opc.Ua.Client.dll… 1.4.356.27
    Opc.Ua.Configuration.dll… 1.4.356.27
    Opc.Ua.Core.dll… 1.4.356.27

    Screenshots, and XML setting are here.

    Thanks for your reply, Josef

    #9560
    josef.novotny
    Participant

    Hi, today i update Rapid Scada from scada_5.8.1_full_en to scada_5.8.3_full_en.
    KpOpcUa.dll… 5.0.0.1
    But problem is the same as previos post.

    Thanks for your reply, Josef

    #9561
    Mikhail
    Moderator

    Hi,
    Please try the update.
    Thank you for finding a bug.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.