incorect format od data recevied

Forum Home Forums Runtime Bugs Server Bugs incorect format od data recevied

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #12161
    Jure
    Participant

    Hello,
    I just installed version 6.02 to test it. Installation finished without errors. But when I try to open SCADA in browser I get following errors:

    2023-03-03 10:10:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 disconnected
    2023-03-03 10:10:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Session with ID -8554438250878693814 created
    2023-03-03 10:10:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 connected
    2023-03-03 10:10:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ERR] Incorrect format of data received from client 127.0.0.1: data length is too big
    2023-03-03 10:11:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 disconnected
    2023-03-03 10:11:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Session with ID 7728946414698059397 created
    2023-03-03 10:11:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 connected
    2023-03-03 10:11:22 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ERR] Incorrect format of data received from client 127.0.0.1: data length is too big
    2023-03-03 10:12:27 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 disconnected
    2023-03-03 10:12:47 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Session with ID 882446067344896114 created
    2023-03-03 10:12:47 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 connected
    2023-03-03 10:12:47 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ERR] Incorrect format of data received from client 127.0.0.1: data length is too big
    2023-03-03 10:13:16 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Session with ID -8993996409445558107 created
    2023-03-03 10:13:16 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ACT] Client 127.0.0.1 connected
    2023-03-03 10:13:16 [DESKTOP-HE47BH6][DESKTOP-HE47BH6$][ERR] Incorrect format of data received from client 127.0.0.1: data length is too big

    I tried different browsers but I get the same error. In WebStationg logs there is nothing. And If I check Instance status, Server and Communicator are normal while WebStation is Not Available.

    #12164
    Mikhail
    Moderator

    Hello,

    Do you have the both Rapid SCADA 5 and 6 on the same computer? If so, you should stop the services of the 1st instance before using the 2nd one.

    In WebStationg logs there is nothing

    Which URL do you use to open the Webstation app?

    #12168
    Jure
    Participant

    No I only have RS 6 installed.

    URL to connect is: http://localhost:10000/

    Port is the same as in Webstation -> Application options

    #12169
    Mikhail
    Moderator

    Use http://localhost:10008/
    10000 is a Server port. When you try to connect it from web browser, Server just reports about errors.
    10008 is the default web app port.

    • This reply was modified 1 year, 3 months ago by Mikhail.
    #12171
    Jure
    Participant

    If I try 10008 I get following error:
    https://imgur.com/a/gMwyDwU

    There is nothing in Webstation logs.

    #12172
    Jure
    Participant

    Also If I go in to ScadaWeb folder and manually run ScadaWeb.exe it creates http server on port 5000. If I then try to open localhost:5000 it opens the login page.

    #12184
    Mikhail
    Moderator

    Check that AspNetCoreModuleV2 is installed as described here.

    #12185
    Jure
    Participant

    I run repair trough AspNetCoreModuleV2 installation and now it works OK. Thank you for the help.

    #12189
    Mikhail
    Moderator

    🙂

    #12972
    loukas konstantinou
    Participant

    i am following this procedure https://rapidscada.net/docs/en/5.8/use-cases/modbus-protocol#customizing-interface and on the Customizing Operator User Interface i cant seem to find where the interface node is in the v6 of Rapid SCADA.

    #12973
    Mikhail
    Moderator

    Hello,
    Please copy the question to the appropriate topic, or create a new topic. This topic is about incorrect data format error.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.