Communication with kepware OPC on window 10

Forum Home Forums Communicating with Devices OPC Communication with kepware OPC on window 10

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #7302
    AvatarNITI
    Participant

    Hi everyone,

    I’m having a trouble about communication with kepware OPC on window 10. I’m using Rapid SCADA vesion 5.1 and KEPServerEx 4.5. I used to try it on window 7 and it worked successfully, but it didn’t work on window 10.
    Here is the error:
    “Error creating data reading subscription: Exception from HRESULT: 0x80040202”

    Hopefully someone knows how to resolve this problem.
    Thanks everyone.

    Best regards,

    NITI

    #7303
    MikhailMikhail
    Moderator

    Hi,

    The links that can help:
    Link 1
    Link 2 (See “Known issue of using OPC”)
    Link 3

    Does KEPServerEx provide OPC UA instead of OPC DA?

    #7304
    AvatarNITI
    Participant

    Hi Mikhail,

    Thank you for your response.

    The KEPServerEx which I’m using it provides OPC DA.
    Here is its link: https://www.kepware.com/en-us/products/kepserverex/

    By the way, I’ve tried to fix the error by following your links, but this error still happened.
    Please let me know if you have any further clue for this case.

    Your sincerely,

    NITI

    #7305
    MikhailMikhail
    Moderator

    Hi,

    Talking about the link 3, what did you do and what results did you get? Please provide more info.

    #7315
    Avatarkumajaya
    Participant

    KEPServerEX 6 expose all tags as OPC UA tags.

    #7317
    MikhailMikhail
    Moderator

    I strongly recommend OPC UA instead of OPC classic when possible

    #7321
    Avatarkumajaya
    Participant

    But now I still fighting why KpOpcUa failed to access NodeOPCUA server with BadIdentityTokenInvalid error. I’ll open a new thread about this problem later.

    #7326
    MikhailMikhail
    Moderator

    I’ll open a new thread about this problem later.

    OK.

    #8688
    Avatartranduong257
    Participant

    Hi every one,
    I have a trouble when connect Rapid Scada to Kepware OPC v6. I have choosed the tag from KepEX but when I click upload configuration, it’s said that “Error uploading onfiguration, there was no endpoint listening at http://localhost:10002/ScadaAgent/ScadaAgentSvc/ that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more detail”.
    Can you tell me what would i do? Thank you!

    #8693
    MikhailMikhail
    Moderator

    Hi,
    It’s not related with OPC. You should start the Agent service. You can find it in Windows service manager.

    #8702
    Avatartranduong257
    Participant

    Hi Mikhail,
    Did you mean the ScadaAgentService in the path Task Manager > Service > ScadaAgentService? I have started it yet, but up load configuration not works 🙁

    #8710
    MikhailMikhail
    Moderator

    Hi,

    You should select an appropriate topic to discuss this issue or create a new one. As I wrote, the cause is not related to OPC and Kepware.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.