Communication stops on device timeout

Forum Home Forums Runtime Bugs Communicator Bugs Communication stops on device timeout

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8709
    AvatarJure
    Participant

    I have two devices on communication line, both of them modbus. Everything works OK if both are working, but If i turn off one communication with it times out and whole communication line stops:

    View post on imgur.com

    Should i change settings to prevent this, or what would be solution?

    View post on imgur.com

    #8712
    MikhailMikhail
    Moderator

    On the screenshot the line seems working.
    Also please provide a screenshot of your communication channel properties.

    #8714
    AvatarJure
    Participant

    If you look at last line it says:”Establish a TCP connection with 192.168.95.112:502″ it is waiting there for few seconds without communicating with other device which is still turned ON.
    With turning off the device i mean turning off the simulator on some PC. Other device that is PLC is still working.

    With communication channel you mean this?

    View post on imgur.com

    #8725
    MikhailMikhail
    Moderator

    Line Parameters – Main Parameters, then Communication Channel group box and the Properties button.

    it is waiting there for few seconds without communicating with other device which is still turned ON

    What date and time on your screenshot?

    #8730
    AvatarJure
    Participant

    Settings:

    View post on imgur.com

    Communication log:

    View post on imgur.com

    As you can see it takes 25 seconds between two reads. But it should read every second. So if I send command in this 25 second window it won’t be sent. Should every device be on it’s own line?

    • This reply was modified 3 weeks, 1 day ago by AvatarJure.
    #8732
    AvatarJure
    Participant

    Sorry second screenshot was wrong:

    View post on imgur.com

    #8749
    MikhailMikhail
    Moderator

    It takes time for waiting 192.168.95.112 at 08:07:43.
    I don’t see the 1st screenshot that may be contains communication channel properties. Could you post it again?

    #8752
    AvatarJure
    Participant

    Correct, it waits because 192.168.95.112 is offline. But because of that 192.168.95.10 is unresponsive.

    I hope that properties work now:

    View post on imgur.com

    #8760
    MikhailMikhail
    Moderator

    You could increase the Reconnect parameter to 30 or 60, for example, to reduce latency when a device is offline.
    Also it can be a good idea to split polling into several communication lines that work in parallel.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.