Windows 10 Pro (x64) – Unable to access web app ?

Forum Home Forums Installation Issues SCADA-Web Installation Windows 10 Pro (x64) – Unable to access web app ?

This topic contains 9 replies, has 2 voices, and was last updated by Mikhail Mikhail 1 year, 8 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2705
    Avatar
    hybrid
    Participant

    Hi there,

    This is my first time with a lot of this so bear with me.

    I’ve installed the software without issue. Setup server and communicator to read in some simple modbus addresses, created table. Works fine.

    I’m trying to connect to web app now but unable to. 127.0.0.1/scada gives me nothing.

    I’m not sure if i have the web application installed correctly. I unziped the Scadaweb folder from the installation folder to the install directory.

    Couldn’t find any option to add this module further ? Do i need to? I’ve seen here that some say the web app in combines with the server now ?

    Screenshots of features here https://postimg.org/gallery/ne637fwc/

    How else can I troubleshoot ?
    Thanks in advance for any help.

    #2706
    Mikhail
    Mikhail
    Moderator

    Hi,
    Features seem OK.
    Try http://localhost/ Does it work?
    Please check, may be the default port 80 is used by another web server?

    #2707
    Avatar
    hybrid
    Participant

    localhost brings me to windows IIS welcome page.

    In scada server controller i have tcp connection port set to 10000. If I go to localhost:10000 I get nothing.

    localhost/scada = nothing also

    localhost/scada:10000 = Server error in ‘/’ Application
    https://postimg.org/image/42crk1x4yj/

    #2708
    Avatar
    hybrid
    Participant

    also the server log is as follows….

    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> ScadaServerService 5.1.0.2 is started
    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> Check the existence of the configuration database files is completed successfully
    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> Input channels are read from the configuration database. Active channel count: 60
    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> Ouput channels are read from the configuration database
    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> Users are read from the configuration database
    2017-10-27 11:42:09 <HYBRID-NOC-PC><SYSTEM><ACT> Formulas are read from the configuration database
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> The formulas source code has been compiled
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> Connection listener is started
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> Start server
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> Current data are loaded
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-10-27 11:42:10 <HYBRID-NOC-PC><SYSTEM><ACT> The user ScadaComm is successfully authenticated
    2017-10-27 11:44:42 <HYBRID-NOC-PC><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-10-27 11:44:47 <HYBRID-NOC-PC><SYSTEM><EXC> Error receiving and processing data from the client 127.0.0.1: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    2017-10-27 11:45:52 <HYBRID-NOC-PC><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-10-27 14:09:46 <HYBRID-NOC-PC><SYSTEM><EXC> Error receiving and processing data from the client 127.0.0.1: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    2017-10-27 14:09:46 <HYBRID-NOC-PC><SYSTEM><ACT> Connect to client 127.0.0.1

    • This reply was modified 1 year, 8 months ago by Avatar hybrid.
    #2710
    Mikhail
    Mikhail
    Moderator

    Don’t use port 10000 for web application. It works on port 80 by default.
    What is shown by http://localhost/scada/Login.aspx ?

    #2718
    Avatar
    hybrid
    Participant

    Hi,
    I changed the tcp port in SCADA-Server to 80. Restarted it. Went to link above and got this https://postimg.org/image/461jjqok2z/

    #2719
    Mikhail
    Mikhail
    Moderator

    It’s better to restore the default values:
    SCADA-Server uses port 10000.
    IIS web server (the web application) uses port 80.

    I suggest to help you by remote connection for a fee. It will save your time.

    #2721
    Avatar
    hybrid
    Participant

    I’m not in a position to pay a fee at the moment unfortunately.

    Apologies for confusion. I will reset Scada-server port to 10000.
    Where should I find the option to check/edit the IIS web server ports ? Is this in scada server control as well or somewhere else ?

    Is there a way to check if the web app is installed correctly ? Should this have been automatic or were steps required? If so can you tell me what they are?

    #2724
    Avatar
    hybrid
    Participant

    I was able to solve it. Followed the manual installation again. The default website in IIS manager did not have ScadaWeb location registered. Seems to be working fine now. Thanks for the help anyway.

    #2727
    Mikhail
    Mikhail
    Moderator

    Cool!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.