OPC Write value issue – Matrikon Simulation

Forum Home Forums Communicating with Devices OPC OPC Write value issue – Matrikon Simulation

This topic contains 5 replies, has 3 voices, and was last updated by Mikhail Mikhail 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3845

    bencyau
    Participant

    I am just using the Matrikon Simulation OPC Server for testing, and I can read all the values desired within RapidScada with no issue.

    Using MatrikonOPCExplorer I can set the “Bucket Bridge.Boolean” between 0 and 1.

    I configured RapidScada Communicator for the above channel as “write data” with a command number 1. Sending command from the Communicator “Commands” tab got “The command was sent successfully”. However, the value in the “Device Data” tab does not seem to change.

    Thanks for your help.

    #3853
    Mikhail
    Mikhail
    Moderator

    Hi,

    The command was sent successfully

    This means just sending to the Communicator service.

    See what is written in the communication line log in Communicator at the moment right after you send a command. You can find logs in C:\SCADA\ScadaComm\Log

    #3861

    bencyau
    Participant

    OK. My mistake found after finding the message below in the line log file:

    2018-06-18 09:25:58 Command execution is disabled by the communication line parameters

    Turns out I missed checking the “Commands Enabled” box in the Communication Line Parameter tab.

    Problem solved, now I can write to the OPC server tags.

    Thank you.

    #3863
    Mikhail
    Mikhail
    Moderator

    Great ))

    #4231

    mariodavid
    Participant

    I’m using an OPC server to connect to a PLC plc s7-300. I did everything that is said above but the value in the “Device Data” tab does not seem to change.

    “2018-09-12 10:41:02 Device 81. Handle current data changing. Subscription: llenado.diesel
    Device 81. Process tag. Name: PLC1.Generic.sensor-nivel-bajo-tanque-prinicipal. Value: True. Quality: good

    2018-09-12 10:41:03 Device 81. Handle current data changing. Subscription: llenado.diesel
    Device 81. Process tag. Name: PLC1.Generic.sensor-nivel-bajo-tanque-prinicipal. Value: False. Quality: good

    2018-09-12 10:41:02 <CONTROL-PC><SYSTEM><ACT> The command is received from file: type=Standard, device=81, number=4”

    i want set the tag to true but
    immediately changes to false

    how can i do?

    • This reply was modified 3 months, 1 week ago by  mariodavid.
    #4240
    Mikhail
    Mikhail
    Moderator

    I answered here.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.