Modbus Byte order for PM2100 Series Meter

Forum Home Forums Communicating with Devices Modbus Modbus Byte order for PM2100 Series Meter

Tagged: 

This topic contains 4 replies, has 3 voices, and was last updated by Mikhail Mikhail 1 year, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3678
    Avatar
    dineshkumargowd
    Participant

    Dear Sir,

    I am trying to read holding register from Schneider Easylogic PM2100 series power meter, but unable to read it. I am getting following errors

    1. Device 102 “11KV Swst” : error
    2018-05-08 09:48:03 Communication session with the Device 102 “11KV Swst”, type: KpModbus, address: 10
    Request element group “Voltage group”
    Send (8): 0A 03 0B CA 00 02 E7 6A
    Receive (5/5): 0A 83 03 70 F3
    Device error: [03] ILLEGAL DATA VALUE!

    I have tried with multiple byte order like ab cd, dc ba, ba dc, cd ab but in every sequency same errors were occurring. Kindly do needful ASAP

    #3679
    Avatar
    manjey73
    Participant

    A link to the list of registers PM2100. Perhaps when prompted in RapidScada need to specify the address of the register + 1

    #3680
    Avatar
    manjey73
    Participant

    https://www.schneider-electric.ru/ru/faqs/FA334611/

    Read the document carefully. The voltage starts from the register 3020, it may be necessary to add to the registers +1, that is, to start with 3021

    Since there is no register between 3018 and 3020, you get an error from the device

    • This reply was modified 1 year, 2 months ago by Avatar manjey73.
    #3682
    Avatar
    dineshkumargowd
    Participant

    Dear Manjey73,

    Yes i have started the addres from 3020 to 3021 and it worked. thanks for your valuable reply.

    #3684
    Mikhail
    Mikhail
    Moderator

    Perhaps when prompted in RapidScada need to specify the address of the register + 1

    In addition, you can choose addressing (zero based or 1 based) in the template settings.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.