Device Template Editor Question

Forum Home Forums Communicating with Devices Modbus Device Template Editor Question

This topic contains 4 replies, has 2 voices, and was last updated by Mikhail Mikhail 3 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1468
    Avatar
    janeoh
    Participant

    Good day,

    Under “MODBUS, Device Template Editor”, I have set up a command (Name, Data table, Element address, Command number).

    What is the “Multiple” and what is “Element count” for command? I don’t see extra items appearing.

    Another question:
    What is the difference between the “Command number” from “MODBUS, Device Template Editor” and the “Command number” from Commands in “SCADA-Communicator”? Further, what “Value” should I send?

    • This topic was modified 3 years, 3 months ago by Mikhail Mikhail.
    #1470
    Mikhail
    Mikhail
    Moderator

    Hello,

    You have to set Multiple command checkbox, if the device manual specifies 0x0F or 0x10 command codes. Element count – number of registers set by a single command.

    What is the difference between

    They must be the same for a command. Command number binds a template with a sent command.

    Further, what “Value” should I send?

    Depending on your device. See the device manual.

    #1471
    Avatar
    janeoh
    Participant

    Good day,

    Thanks for replying.

    The Address for the Command Code is 00A0h. The Hex Address is 00A0, with a Range of Low = 1 and High = 12.

    Command Code Function Modbus Function Code
    01 Open 06h, 10h
    02 Close 06h, 10h
    03 Reset Targets 06h, 10h
    04 Trigger 06h, 10h
    … etc. up to Command Code 11

    How do I interpret this from the device manual? What do I put in the “MODBUS, Device Template Editor”? What do I give as a value?

    The manual says that 06h, 10h are the “Modbus function code used to initiate the related command code”

    Thanks,
    Jane Oh

    #1472
    Avatar
    janeoh
    Participant

    Good day,

    Thanks! I’ve got it!
    I just left the Multiple unticked and set the Command Number to 1.

    Regards,
    Jane Oh

    • This reply was modified 3 years, 3 months ago by Avatar janeoh. Reason: Clarity
    #1475
    Mikhail
    Mikhail
    Moderator

    Wise 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.