Webpage Error Localhost and Remote

Forum Home Forums Installation Issues Webpage Error Localhost and Remote

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #2725
    AvatarAnonymous
    Inactive

    Installation on Windows 7. Webpage was working on Localhost and remote PCs. I shut the server down and moved it to its permanent location (On the same network) now web page will not load on either Localhost or remote PCs. Thanks for the help, Rob

    Server Error in ‘/Scada’ Application.

    Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.TypeLoadException: Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [TypeLoadException: Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.]
    System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type) +0
    System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName) +70
    System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +40
    System.Type.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +37
    System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +65
    System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +38

    [ConfigurationErrorsException: Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.]
    System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +353
    System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, Boolean checkAptcaBit) +21
    System.Web.Configuration.Common.ModulesEntry.SecureGetType(String typeName, String propertyName, ConfigurationElement configElement) +39
    System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement) +42
    System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) +160
    System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) +1068
    System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +82
    System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +172
    System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +339
    System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +296

    [HttpException (0x80004005): Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9946132
    System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +90
    System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +261

    #2728
    MikhailMikhail
    Moderator

    Please provide a screenshot of your Windows features dialog. I suppose, WCF was not installed.

    #2745
    MikhailMikhail
    Moderator

    The screenshot is not accessible.

    #2748
    AvatarAnonymous
    Inactive
    #2749
    AvatarAnonymous
    Inactive
    #2752
    AvatarAnonymous
    Inactive
    #2754
    AvatarAnonymous
    Inactive
    #2755
    AvatarAnonymous
    Inactive

    I added new links above. The fist two are Windows features. The next two are error on Localhost and error on Remote respectively. Thanks a bunch for the help.

    #2759
    MikhailMikhail
    Moderator

    Disable activations subitems of .Net 3.5.1 node. This is important.

    #2764
    AvatarAnonymous
    Inactive

    That allowed the webpage to come up on Localhost but not on remote. Also the webpage log in page loads, I log in, the menus do not work, the scheme will not load, and a few seconds later the page closes and re-opens the Login page, consistently.

    #2765
    AvatarAnonymous
    Inactive

    Correction. Remote computers net the same result as Localhost.

    #2766
    MikhailMikhail
    Moderator

    Press F12 in the browser, quickly open the Console tab and make a screenshot.

    #2771
    AvatarAnonymous
    Inactive

    https://drive.google.com/file/d/1Dew4wIbM69nbS9ogzGePelqs7kpnwwkc/view?usp=sharing

    Thank you very much for the help. If we can get this going reliably I might be interested in paying for support if those services are available.

    #2772
    MikhailMikhail
    Moderator

    I think, we haven’t repaired WCF (Windows Communication Foundation) yet.
    Also make a screenshot of the http://localhost/scada/ClientApiSvc.svc

    When we work on Windows 7, WCF 4+ is installed as a part of .NET Framework. What version of .NET Framework is currently installed? Please make a screenshot of the installed programs where we can see Microsoft .NET.
    The most fresh framework is 4.7.1. I recommend to update to this version from https://www.microsoft.com/net/download/windows

    #2776
    AvatarAnonymous
    Inactive

    The .NET update fixed it. Thanks again for the great support!!!

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.