Web Application on Windows Server 2012 R2

Forum Home Forums Installation Issues SCADA-Web Installation Web Application on Windows Server 2012 R2

This topic contains 4 replies, has 2 voices, and was last updated by  DragonFire 1 year, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2005

    DragonFire
    Participant

    Before anything else, I would like to say thank you for creating this awesome piece of software. It does what I need it to do, minus a small issue, but, again, thanks for creating RapidSCADA.

    Now, for my issue, I am having a difficult time getting the web application to work on a Windows Server 2012 R2 machine. I’ve read all the documentation and watched all the videos as well on the topic but as most know, Windows Server is slightly different than its Desktop counterparts. The issue seems to be getting all the IIS parts right. Since Server 2012 R2 is neither Windows 7 or Windows 10, how do I go about installing the right .NET version and IIS components? I get this any time I try to connect to the web server (this is just a generic image of my issue):

    Fix Connection

    Should I go the route of following the Windows 7 IIS setup instructions since Windows Server 2012 R2 doesn’t have access to ASP.NET 4.6? Thank you for your time.

    • This topic was modified 1 year, 10 months ago by  DragonFire.
    #2007
    Mikhail
    Mikhail
    Moderator

    Hello,
    Thank you for the kind words.

    You right, Windows Server requires different sequence of installing IIS. Could you provide screenshots to show the settings you have already done? What components did you choose?
    Something like
    postimage

    #2008

    DragonFire
    Participant

    Here are a few screenshots that cover my config in Server Manager and in IIS Manager:

    Int_AMRS-SRV-2017-03-15-16-56-18<br/><br/>
    Int_AMRS-SRV-2017-03-15-20-36-21<br/><br/>
    Int_AMRS-SRV-2017-03-15-20-37-46<br/><br/>
    Int_AMRS-SRV-2017-03-15-20-39-00<br/><br/>
    <br />forum image hosting<br /><br />

    Hope these help. Thanks for the fast response!

    • This reply was modified 1 year, 10 months ago by  DragonFire.
    #2010
    Mikhail
    Mikhail
    Moderator

    Thank you.
    Also you have to switch on ASP.NET 4.5 and HTTP Activation for WCF 4.5
    What do you see by the link http://localhost ?

    • This reply was modified 1 year, 10 months ago by Mikhail Mikhail.
    #2016

    DragonFire
    Participant

    Wow, I feel very stupid right now. I forgot that Windows Server locks down Internet Explorer. I installed Vivaldi and it works like a champ! Thanks for your assistance even though it was an issue I should have realized sooner hahaha.

    postimage

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.