Unknown device tags

Forum Home Forums Communicating with Devices Unknown device tags

This topic contains 20 replies, has 3 voices, and was last updated by Avatar GVG 2 weeks ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #5651
    Mikhail
    Mikhail
    Moderator

    Is it possible that this tags are blocked to use them outside OPC server?

    May be, but I don’t think so.
    Matrikon also provides OPC Explorer. Try to use it for get data of that tags. Does it work?

    I can connect to your PC remotely to do more diagnostic, however this is a commercial service and I’m not sure that I reach success in fixing this problem.

    I tried restarting communicator and also setting the tag´s names from administrator but still not work.

    Please provide communication line log.

    #5653
    Avatar
    GVG
    Participant

    Yes, everything is working good except when trying to add certain tags.
    I tryed changing the Data Specification in Communicator and also changing the Item Data Type in Item Properties.

    I provide Line Logs and other screenshots.

    https://www.dropbox.com/s/1h3v90wt2n77xdj/MatrikonServerTags.JPG?dl=0
    https://www.dropbox.com/s/cm9kzlnvdmpncbz/TagsProperties.JPG?dl=0
    https://www.dropbox.com/s/y2c4bev3rwz0rxb/Captura4.JPG?dl=0
    https://www.dropbox.com/s/jedtlkl19sudk13/Captura5.JPG?dl=0
    https://www.dropbox.com/s/d5n4q8ufb4iumol/Captura7.JPG?dl=0

    #5655
    Avatar
    GVG
    Participant

    Ok, Configured the aliases in OPC server. Now I have access to them from communicator service and it is now working. I didn´t know that the use of aliases was needed.

    Thank you very much for your time!

    #5656
    Avatar
    manjey73
    Participant

    Does your PLC work via Ethernet or com port ? Can you make a log of Wireshark or monitoring program for COM port and put on the file exchanger ?
    With the exact model of PLC ? and the type of exchange Protocol ?

    • This reply was modified 2 weeks ago by Avatar manjey73.
    #5660
    Mikhail
    Mikhail
    Moderator

    Configured the aliases in OPC server. Now I have access to them from communicator service and it is now working. I didn´t know that the use of aliases was needed.

    That’s good! Thank you for sharing the cure recipe. OPC is a black box.

    #5664
    Avatar
    GVG
    Participant

    Sure, it is an Allen Bradley Compactlogix L33ER EtherNet/IP. The used protocol is OPC. Here is the Wireshark Log, of course some of the parcels shown here were inexistent before installing the OPC server.

    https://www.dropbox.com/s/1kosqtb7yhq3zwk/WiresharkLog.pcapng?dl=0

Viewing 6 posts - 16 through 21 (of 21 total)

You must be logged in to reply to this topic.