Run Self ssl to secure scada

Forum Home Forums Uncategorized Issues Run Self ssl to secure scada

This topic contains 5 replies, has 2 voices, and was last updated by  SuperDev 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4611

    SuperDev
    Participant

    Hi
    I installed self ssl in windows and checked the scada to be ok. everything is ok and scada is running on HTTPS. but the only problem is loading the schemes that are beign load within iframe (e.g frameview).
    The below error is shown:
    “Scheme loading failed. Try to reload scheme”
    i think we are having mixed content problem with iframe.
    What should we do?

    #4613
    Mikhail
    Mikhail
    Moderator

    Hi,

    Thanks for this question.
    Use this update special for HTTPS.

    #4616

    SuperDev
    Participant

    Thanks for rapid reply.
    yet some problems remain as belows:
    1. I replaced all of the web.configs as mentioned in the folders and the below error occured.
    iis error for web.config

    2. I replaced only web.config of Scheme. the above problem solved and scheme loading problem solved too. but the below error is shown:
    Error updating scheme data
    scheme error update

    #4623

    SuperDev
    Participant

    Fortunately the problem solved.
    The reason wasn’t rapidscada. The iis was causing the problem.
    Remember to config URL Rewrite while configing iis and installing ssl.
    complete introduction and help is in the link below:
    https://www.namecheap.com/support/knowledgebase/article.aspx/9953/38/setting-up-an-httphttps-redirect-in-iis

    Remember:
    after you created a rule for url rewrite, a web.config file will be created in C:\inetpub\wwwroot. go to this path, open the web.config file and remove rewrite section and save and Enjoy

    #4625
    Mikhail
    Mikhail
    Moderator

    Thank you for the info.

    #4630

    SuperDev
    Participant

    you’re welcome sir

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.