Regional Number Configuration

Forum Home Forums Uncategorized Issues Regional Number Configuration

This topic contains 6 replies, has 2 voices, and was last updated by Mikhail Mikhail 3 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4314
    ngiussani
    ngiussani
    Participant

    Hi,

    First of all, I looked up for this issue in the forum, and didn’t find nothing similar. If there is one, sorry.

    I coudn’t find a simple way to choose how numbers are displayed, it is decimal and thousands separators. In my country, the decimal separator is a comma and the thousands is a dot.

    #4315
    Mikhail
    Mikhail
    Moderator

    Hi,

    You need to set culture in the settings of Webstation. For example, en-US

    #4322
    ngiussani
    ngiussani
    Participant

    Hi Mikhail,

    It’s already configured with correct culture. But, still, I have the same number format. I don’t know what else could be missing.

    For reference, this is the line in the WebSettings.xml

    <Param name=”Culture” value=”es-LA” descr=”Web application culture” />

    Additionally, the laguage of the app wasn’t changed. I had to rename the lang files form spanish to en-GB to make it work.

    #4323
    Mikhail
    Mikhail
    Moderator

    Hi,

    I tried the same:
    1. Copy ScadaData.es-LA.xml and ScadaWeb.es-LA.xml to C:\SCADA\ScadaWeb\lang
    2. Open http://localhost/Scada/plugins/Config/WebConfig.aspx and set Culture to es-LA
    3. Logout and login
    And Spanish language become active.
    I use Webstation 5.0.6.1. What is your version?
    Note: some phrases are not translated. Update of language files, made by the community, is desirable.

    #4324
    Mikhail
    Mikhail
    Moderator

    I don’t see es-LA here https://msdn.microsoft.com/en-us/library/hh441729.aspx
    I think, there is no such supported culture. To get required number formats, we have to use correct culture name, e.g. es-MX or just es
    And rename language files. We need community help to update files and choose the culture.

    #4327
    ngiussani
    ngiussani
    Participant

    Thanks Mikhail. Setting culture as “es” did the trick.

    I made some improvements on the language files, but not enough to send it as official. As soon as I have some free time, I’ll work on them and generate the entire language files for “es”. Once again, your support is very appreciated.

    #4331
    Mikhail
    Mikhail
    Moderator

    Update files for Webstation. Other apps are going to be totally changed.
    Thank you.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.