MQTT in-depth Installation Help

Forum Home Forums Communicating with Devices MQTT in-depth Installation Help

Tagged: 

Viewing 9 posts - 16 through 24 (of 24 total)
  • Author
    Posts
  • #6249
    AvatarALnaluk
    Participant

    Error log

    https://www.234.in.th/image/0XBMe

    And this xml config

    <?xml version=”1.0″ encoding=”utf-8″?>
    <DevTemplate>

    <MqttParams Hostname=”tailor.cloudmqtt.com” ClientID=”” Port=”15043″ UserName=”pscmbdmc” Password=”pscmbdmc”/>
    <RapSrvCnf ServerHost=”127.0.0.1″ ServerPort=”10000″ ServerUser=”ScadaComm” ServerPwd=”12345″/>
    <MqttSubTopics>
    <Topic TopicName=”/mesparam1″ QosLevel=”0″ NumCnl=”600″/>
    </MqttSubTopics>
    <MqttPubTopics>

    </MqttPubTopics>
    <MqttSubCmds>

    </MqttSubCmds>
    <MqttSubJSs>

    </MqttSubJSs>

    </DevTemplate>

    • This reply was modified 6 months, 2 weeks ago by AvatarALnaluk.
    #6253
    greenfoxxgreenfoxx
    Participant

    Please check connect with tailor.cloudmqtt.com using other emulator programs, for example mqtt-spy.

    #6260
    AvatarALnaluk
    Participant

    when i use node-red connect cloud mqtt can connected but when i use mqtt-spy doesn’t connect to cloud mqtt

    This link video

    #6261
    AvatarALnaluk
    Participant

    now i can use mqtt-spy connected.help me use rapid scada connect

    #6262
    phachakornphachakorn
    Participant

    I also encountered the same problem.

    This message in Line Log

    2019-12-25 13:40:25 Error executing actions of Device 52 “MQTT” on communication line terminating: Object reference not set to an instance of an object.

    2019-12-25 13:40:25 Stop communication line 6 “MQTT”
    ——————————————————————————–
    ——————————————————————————–
    2019-12-25 13:43:47 Initialize communication line 6 “MQTT”
    2019-12-25 13:43:47 Error executing actions of Device 52 “MQTT” on adding device to communication line: Could not find a part of the path ‘C:\SCADA\ScadaComm\Config\’.
    2019-12-25 13:43:47 Start communication line 6 “MQTT”

    2019-12-25 13:43:47 Communication session with the Device 52 “MQTT”, type: KpMqtt
    Error reconnecting

    2019-12-25 13:43:47 Communication session with the Device 52 “MQTT”, type: KpMqtt
    Error reconnecting

    2019-12-25 13:43:47 Communication session with the Device 52 “MQTT”, type: KpMqtt
    Error reconnecting

    2019-12-25 13:43:47 Communication session with the Device 52 “MQTT”, type: KpMqtt
    Error reconnecting

    #6267
    greenfoxxgreenfoxx
    Participant

    to phachakorn:
    Please check Communication Lines->Request Sequence -> Column Command Line.
    You need to write KpMqtt_Config.xml in this column and than Upload Configuration.
    If a file name KpMqtt_Config.xml has already been written in this column, just Upload Configuration.

    to ALnaluk:
    Please show connection settings in working mqtt-spy and compare with <MqttParams Hostname=”tailor.cloudmqtt.com” ClientID=”” Port=”15043″ UserName=”pscmbdmc” Password=”pscmbdmc”/>

    #6268
    greenfoxxgreenfoxx
    Participant

    UPD to ALnaluk:
    try to Upload Configuration again

    #6273
    AvatarALnaluk
    Participant

    i can do it.thank you for support

    #6275
    phachakornphachakorn
    Participant

    to greenfoxx
    it Works.
    Thanks you.

Viewing 9 posts - 16 through 24 (of 24 total)
  • You must be logged in to reply to this topic.