Modbus WAGO

This topic contains 7 replies, has 2 voices, and was last updated by Mikhail Mikhail 2 years ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2673
    Avatar
    peter_f
    Participant

    Hi,
    I try to read data from a WAGO 880 Controller. Wago provides the values in Register 12288 – 24575. I tested this with modbus poll. If I read Modbus address 12288, i found the Value of IEC-61131-Address 0. So I think, there should be an opportunity to adjust an offset. Maybe i just overlook that part of the documentation.
    Is there someone who had the same problem?

    #2675
    Avatar
    peter_f
    Participant

    What I forgot to say ist, that I tried to solve this problem by inserting 12288 in the Address-column of Device table. This was not successful.

    #2676
    Mikhail
    Mikhail
    Moderator

    Hi,
    Do you mean the address offset specified for a device or specified for SCADA?

    #2678
    Avatar
    peter_f
    Participant

    Hi Mikhail,

    in the manual of the WAGO-Controller stands that the Modbus-Addressrange is from 12288 to 24575. If I use Modbuspoll to read the values without giving an offset, I get the same strange result as in rapid scada. In Modbus poll there is a window called Read/write Definition where i can define an address (It seems to be somethin like a startaddress). If I define 12288 as address I can read the Addresses above 12288 with the correct value. The equivalent setting in rapid scada seems to be in the template. There is a field start element address. If I write at this point 12288, it causes errors.
    So I would say that the values are not at that position scada expects. I think this is a problem of WAGO but I hope scada can handle it.
    Is this what you need to know?

    #2681
    Avatar
    peter_f
    Participant

    The problem seems to besolved solved.
    The range 12288 to 24575 is Modbus-address. I don’t kow why, but apparently rapid scada divides 1, so that scada address 1 appears as standart Modbus-address 0. I set the offset to 12288 so I requested data from standart address 12287. This is a reseved range with no valid data. This seems to be the reason for the occured error.

    #2682
    Mikhail
    Mikhail
    Moderator

    In the new version of the Modbus driver you can switch the addressing base: 0 or 1. See Figure 10 of http://doc.rapidscada.net/content/en/use-cases/modbus-protocol.html

    #2686
    Avatar
    peter_f
    Participant

    Thanks for that information. I got the current version but sadly I haven’t seen that there is a checkbox to solve just that problem.

    #2688
    Mikhail
    Mikhail
    Moderator

    OK 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.