How to set the number after the comma to 2 digits (Elastic Report)?

Forum Home Forums Understanding the Software How to set the number after the comma to 2 digits (Elastic Report)?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #10378
    ilhampngst_
    Participant

    Hi Mikhail,

    How to set the number after the comma to 2 digits (Elastic Report)?

    https://ibb.co/5Lg4p2N

    <Column name="Consumption/day" cnlNum="9405" calcType="Diff" calcTotal="true" calcAvg="true" calcMin="true" calcMax="true" />

    • This topic was modified 1 month, 3 weeks ago by ilhampngst_.
    • This topic was modified 1 month, 3 weeks ago by ilhampngst_.
    #10381
    Mikhail
    Moderator

    Hi,

    It uses format of the input channel. Check that it is set.

    #10382
    ilhampngst_
    Participant

    No, i mean how to decrease decimal of calcAvg=”true”
    because by default the result of calcAvg=”true” is 10.12903226 and I just want to change it to 10.12

    #10385
    Mikhail
    Moderator

    Could you publish a screenshot of the channel 9405 properties?
    What output format do you use, HTML, PDF or Excel?

    • This reply was modified 1 month, 2 weeks ago by Mikhail.
    #10389
    ilhampngst_
    Participant

    Hi mikhail,
    This is the properties channel 9405
    https://ibb.co/j6p2BCh

    This is input channel 9405
    https://ibb.co/9qX2WFS

    This is the code
    https://ibb.co/vHv64jg

    This is the output i use is excel
    https://ibb.co/HnS2Ktw

    #10392
    Mikhail
    Moderator

    Hi,

    Thank you for the screenshots. The settings seem OK.
    What version of Elastic Report is in use? It is displayed by the Webstation app on the plugins page.
    What output format do you use, HTML, PDF or Excel?

    #10393
    ilhampngst_
    Participant

    This version of elastic report i use
    https://ibb.co/JttVsT8

    I use excel for the output

    #10395
    Mikhail
    Moderator

    The plugin version is up to date.
    Does the error appears on PDF and HTML formats?

    #10397
    Merdock
    Participant

    What I see in the properties of channel 9405 is that it is configured to show the value without decimals.
    You can double the channel and set it to 2 decimal places.

    #10400
    Mikhail
    Moderator

    I guess, that the issue is related to Excel format. In the channel properties there are no decimals, but in the cell there are a lot of digits after decimal separator.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.