AT command GSM

Forum Home Forums Understanding the Software AT command GSM

This topic contains 8 replies, has 3 voices, and was last updated by Mikhail Mikhail 1 week, 2 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5464
    Avatar
    scadarapid
    Participant

    It is possible to use AT command with GSM.

    #5465
    Mikhail
    Mikhail
    Moderator

    KpSms.dll allows sending custom AT commands.
    Command number: 2
    Command type: binary
    Command data: AT command

    #5467
    Avatar
    scadarapid
    Participant

    Hi.

    How can we send AT Command?
    Can you example for me please ?

    Thank you so much.

    #5468
    Avatar
    scadarapid
    Participant

    Now I can send the SMS.

    I use the example Cinterion MC52iT and use command number 2.
    First I add input channel 302(output channel 301) by using Table Editor to show on the web. then I set my ScadaCommunication. after that I go to the web page and send SMS to my phone number

    choose String type
    +66123456789;MessageTosendToyourMobile
    if your number 0755487965 , change you 0 number to +66 then follow the next number.
    +66755487965.

    Thank you so much

    #5471
    Mikhail
    Mikhail
    Moderator

    Thank you for the example 🙂
    If this is a real phone number, it’s better to change it here.

    #5906
    Avatar
    fjyyj
    Participant

    hi
    SMS LINE->line stats ->line log
    2019-09-05 18:47:40 Communication session with the Device 2 “SMS Send”, type: KpSms
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data

    2019-09-05 18:48:10 Communication session with the Device 2 “SMS Send”, type: KpSms
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data

    2019-09-05 18:48:40 Communication session with the Device 2 “SMS Send”, type: KpSms
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data
    Set echo off
    Send: ATE0
    Receive: no data
    —————–
    Sending with Serial Port Tool:
    41 54 45 30 0D 0A
    SMS module return:
    0D 0A 4F 4B 0D 0A
    ———————-
    Thank you so much

    #5911
    Mikhail
    Mikhail
    Moderator

    Hi,
    The modem doesn’t respond. First of all, check serial port settings in Rapid SCADA.

    #5919
    Avatar
    fjyyj
    Participant

    Hello
    port setting
    PortName = COM5
    BaudRate = 9600
    DataBits = 8
    Parity = None
    StopBits = One
    DtrEnable = False
    RtsEnable = False
    Behavior = Master

    #5923
    Mikhail
    Mikhail
    Moderator

    Use Hercules to make sure that your modem supports ATE0 command.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.