StevenYX

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: OPC on Remote PC #8954
    StevenYX
    Participant

    Hello Mikhail,

    Thanks for the reply.
    I got it work as the posts #8942 and/or #8943….(it’s not TCP/IP ports, it’s IP address)

    (It has been notised that there are a lot of posts about TCP/IP ports, would be better the installation execution file can check if those ports are free.)

    Thanks again!

    Steven

    in reply to: OPC on Remote PC #8943
    StevenYX
    Participant

    Workaround solution:

    1. Install RapidSCADA fully on both A and B computer

    2. On A computer(on which there is OPC server),
    a. Create a new communicaiton line
    b. Create a new devie
    c. Create new Input channels and output channels
    d. Create new communication line in Instance

    all above can do them according training videos

    Local OPC on local server( A computer should work now)

    3. repeat the save steps on B computer
    or copy all files from A to B (did not test, but must work)

    4. copy all the files in the fold SCADA\ScadaComm\Config
    from A computer to B computer

    5. Stop ScadaServerService on A computer
    6. Stop ScadaCommservice on B computer

    7. Change Common Parameters (server) to B computer IP address
    8. Change Connection Settings (server) to A computer IP address
    9. Upload

    Done

    in reply to: OPC on Remote PC #8942
    StevenYX
    Participant

    On A computer, IP: 192.168.10.111
    Edit ScadaCommSvcConfig.xml in the fold: c:\SCADA\ScadaComm\Config

    <CommonParams>
    <Param Name = “ServerHost” value = “192.168.10.106” (was 192.168.10.111)

    Keep all the other the same

    stop ScadaCommservice, start ScadaCommservice

    On B computer, IP: 192.168.10.106
    Instance–>Default–>communicator–>[2]OPC–>[21]OPC Demo
    three tags are there, and updating
    Instance–>Default–>communicator–>[2]OPC–>Line Stats–>Active Device 1. Device 21 “OPC Demo”: Normal

    However:

    Instance–>Default–>Communicator–>[2]OPC–>Line Parameters–>Request Sequence–>Properties–>OPC server got “<No available servers>

    Should Call Number or host name be 192.168.10.111?

    Best Regards

    Steven

    in reply to: OPC on Remote PC #8941
    StevenYX
    Participant

    Hello Mikhail,

    1. A computer, IP: 192.168.10.111,
    installed: MatrikonOPC Server; ScadaAgent and ScadaComm(of RapidSCADA)
    2. B computer, IP: 192.169.10.106,
    installed: RapidScada (except of ScadaComm)
    Configure:
    Common Parameters: server: 192.168.10.111(A computer IP address)
    Connection Settings Server: 192.168.10.111
    Upload: got “Unable to login – Error validating user

    3. copy BaseDat from B computer to A computer
    Upload: “Upload competed successfully. Duration:0 Sec. Data size 230383 bytes”

    4. A computer: stop ScadaCommservice, then start ScadaCommservice
    5. B computer:
    Instance–>Default–>Server–>Stats got “File not found”
    Instance–>Default–>Communicator–>Communication Lines–>Stats got
    connect to SCADA-Server “192.168.10.111”
    Error Connecting to SCADA-server: No connection could be made because the target machine actively refused it 192.168.10.111:10000
    Disconnect from SCADA-Server
    Unable to start operation due to SCADA-Server communication Error

    Both A and B computer’s fire wall are off
    Port 10000, 10001, 10002, 10010 are opened

    What’s wrong?

    thanks in advance

    Steven

    in reply to: OPC on Remote PC #8907
    StevenYX
    Participant

    Hi Mikhail/scadakid,

    Could you please make an instruction how to integrate OPC DA/UA remotely?
    Also how to add a new instance?

    Thank you very much!

    Steven

Viewing 5 posts - 1 through 5 (of 5 total)