Jure

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • in reply to: MQTT #8862
    AvatarJure
    Participant

    I don’t see any images that contains formulas. If you add them, I will check.

    Is imgur working OK for you? Because above I see one image view where if you move right or left you can swap images so in total are 3.

    This is image with formulas:

    View post on imgur.com

    As you can see, all that I do is Cnl / 10 and Cnl – 10.

    As wrote above, the result of formulas can be displayed by views, not in Communicator.

    I know that you can see result of formulas, that is why there is also image of view. You can see in event log that formula is used multiple times per second, so probably is used on every program iteration:

    View post on imgur.com


    Could you provide more info about that?

    I am not sure what more info I can give, I will try to describe process in more details. I have two computer and PLC in same LAN.
    Mqtt PC: It runs Mqtt client that is based on Mqtt Paho Java
    Server PC: It runs SCADA and Mqtt broker
    PLC from where we read values and change them

    1. Rapid SCADA is running.
    2. I start mqtt client.
    3. Mqtt client retrieves values and updates topic values. I don’t use .js just plain topic values.
    4.Mqtt broker acknowledges new topic values and publishes them to Rapid Scada. Like I said in short time there are around 80 topics published. It can take up to 1 minute or probably even more for communicator to update all values.
    I tried with just on topic and it can take from 4-10 seconds for topic to be updated in communicator.

    We also support the existing MQTT driver.

    That is great. Currently we made all of the testing in the office and SCADA was accessible just in LAN. But if we can solve problem with formulas and events there is plan to test on some real project where SCADA would be accessible from outside our LAN and we would monitor location in some other company.

    in reply to: MQTT #8856
    AvatarJure
    Participant

    I also noticed that Rapid SCADA takes quite some time to read data from Mqtt broker. When around 80 variables is published to Rapid SCADA it takes more then 1 minute to show all the data.
    If I send command from Rapid SCADA -> PC -> PLC communication is much faster.

    If we choose Rapid SCADA for our projects can we count on official support or is Mqtt community developed and so unofficial?

    in reply to: MQTT #8855
    AvatarJure
    Participant

    As you can see on my images I have two formulas:
    Cnl – 10
    It looks like it is done on each cycle of program. Because of that value gets lower on each cycle.
    Cnl / 10
    This formula is never caluclated. Value is all the time the same as in communicator.

    in reply to: MQTT #8847
    AvatarJure
    Participant

    Now one formula is working, but it doesn’t execute just once, but whole time. So – operator works, but / doesn’t work.

    View post on imgur.com

    I hope that you can see all three images: device, channels and web browser view.

    • This reply was modified 3 days, 1 hour ago by AvatarJure.
    in reply to: MQTT #8846
    AvatarJure
    Participant

    From the last time I was able to make MQTT working. Data and commands are successfully transferred. But I have another question. Is it possible to use formulas for input channels that are using MQTT? Or should I use formulas inside mqtt.xml file? And how is with events and alarms?

    in reply to: Communication stops on device timeout #8752
    AvatarJure
    Participant

    Correct, it waits because 192.168.95.112 is offline. But because of that 192.168.95.10 is unresponsive.

    I hope that properties work now:

    View post on imgur.com

    in reply to: Communication stops on device timeout #8732
    AvatarJure
    Participant

    Sorry second screenshot was wrong:

    View post on imgur.com

    in reply to: Communication stops on device timeout #8730
    AvatarJure
    Participant

    Settings:

    View post on imgur.com

    Communication log:

    View post on imgur.com

    As you can see it takes 25 seconds between two reads. But it should read every second. So if I send command in this 25 second window it won’t be sent. Should every device be on it’s own line?

    • This reply was modified 3 weeks, 1 day ago by AvatarJure.
    in reply to: Communication stops on device timeout #8714
    AvatarJure
    Participant

    If you look at last line it says:”Establish a TCP connection with 192.168.95.112:502″ it is waiting there for few seconds without communicating with other device which is still turned ON.
    With turning off the device i mean turning off the simulator on some PC. Other device that is PLC is still working.

    With communication channel you mean this?

    View post on imgur.com

    in reply to: MQTT Issue #8708
    AvatarJure
    Participant

    I have similar problem. If I connect to broker trough client it works, but if I try to set up connection in Rapid SCADA I get same error. I followed youtube tututorial.

    in reply to: Interface reverted to older version #8685
    AvatarJure
    Participant

    It was my error. I opened with editor file in SCADA/Interfaces instead inside the project. So when I saved the file it would show changes on website. But when I built the project again and uploaded it to server it has overwritten changes.

    in reply to: Interface reverted to older version #8672
    AvatarJure
    Participant

    I understand now what is the problem, i was editing files in interface which is built from project/interface.

    in reply to: Interface reverted to older version #8671
    AvatarJure
    Participant

    It must be something else, I crated new elements by hand and they again disappeared on upload.

    in reply to: Interface reverted to older version #8670
    AvatarJure
    Participant

    Well I didn’t know that it is automatically cleared and this is just a test project, so that we can see if this software fits our needs.

    I managed to find the reason for problem:
    If I copy elements from interface 1 to interface 2 and save interface 2, everything is ok.
    But if I upload whole project, then all copied elements will get deleted. Even if I copy copied element. And since I wanted my elements to look the same in interface 2 as in interface 1 all elements were copies.
    Is it possible to fix this? Because it easier to build new interface if you can copy elements from existing interface, especially if you want them to have same design.

    in reply to: Interface reverted to older version #8659
    AvatarJure
    Participant

    I recreated the interface and everything was OK. I made backup copy for both of my interfaces inside the “Inteface” folder.. After that I made some changes in administrator and uploaded complete project and interface was overwritten again. Besides that both backups were deleted.
    is it possible that there is huge bug or am i doing something wrong?

Viewing 15 posts - 1 through 15 (of 25 total)