Pieter

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • in reply to: Remote commumicator #4037
    Pieter
    Participant

    rsepulve,
    I am not currently at home to get the information you require. I will only return home mid next week.
    I will then take screendumps of my settings and post them.

    in reply to: Remote commumicator #3715
    Pieter
    Participant

    I got it working. I was trying to create different channel on the administrator app.
    It should have been the exact same as the remote settings and channel numbers.
    I happy now. Loving this software every week more and more.

    in reply to: arduino #3648
    Pieter
    Participant

    I found it. I used this modbus slave labrary here.

    It was a bit difficult to set it up first because I was used to mgsmodbus.

    in reply to: arduino #3635
    Pieter
    Participant

    Update: I can confirm that the Nano v3, and the Uno aswell as the Nano loaded with optiboot can work with Rapid scada via modbus RTU.
    I can not remember where I downloaded the modbus slave library.
    I suppose any modbus slave library should work.
    I will try to locate it in github.
    MGSmodbus does not support rtu.

    • This reply was modified 3 years, 7 months ago by Pieter.
    • This reply was modified 3 years, 7 months ago by Pieter.
    in reply to: arduino #3558
    Pieter
    Participant

    I suppose it would work with a nano aswell via serial coms.
    I have one sonewhere, will find it and test.

    in reply to: Installation has completed with errors #3557
    Pieter
    Participant

    I had same problem once. Turned out I did not switch all the right features ON.
    Instructions is in the install folder.

    in reply to: Unable to retrieve tags (Rockwell) #3556
    Pieter
    Participant

    Rapid scada works Allen bradley PLC.
    Use rslinx oem on the same machine as Rapid scada, or use rslinx gateway if rapid scada is on deffirent computer.
    Kepserverex with Controllogix driver also works.
    The tag name inside the opc server would be the same as the tag name inside the plc.

    I have success using kepserverex with rapid scada.

    in reply to: Modbus Slave mode #3508
    Pieter
    Participant

    Are you running a modbus simulator on the same computer?
    Have you tried stopping line 1.
    Line 1 and Line 8 are both using same database and settings.
    Might be conflicting.
    I do not know much, only just stared using Rapid scada with my modbus devices this week.

    in reply to: arduino #3503
    Pieter
    Participant

    I have used it with arduino mega and uno using w5100 ethernet shield.
    I have not tested it with nano.

    in reply to: Value scaling #3498
    Pieter
    Participant

    I found the problems.
    Communicator had two modbus lines looking at the same device. Thats issue one.
    Second. I used the same signal number in my calculated value as in my main channel number. That caused the communicator to change to that signal which never updates again.

    in reply to: Invert command logic #3497
    Pieter
    Participant

    Thank you. I just tested it. Now it works as I expected it to work.
    Your formula is 100% accurate.

    in reply to: Value scaling #3496
    Pieter
    Participant

    I have watched the videos on youtube carefully.
    I will start from scratch using only the one register value. Might be something conflicting.

    in reply to: arduino #3494
    Pieter
    Participant

    Arduino library to use arduino as modbus device.

    “The library gives the program the possibility to be a master, a slave or both on a TCP network.
    The Modbus functions 1, 2, 3, 4, 5, 6 15 and 16 are implemented.”

    I have used this library successfully with kepserver enterprise and Kepware to communicate with Rockwell Factory talk view SE and panel views.

    in reply to: Value scaling #3493
    Pieter
    Participant

    Thank you manjey73. That is the exact formula i added.

    It does not crash completely. I just do not get any information from it.
    Input channel 23 is my modbus register that contains the byte value.

    When I add the input channel to say 203, then I add the formula on 203 to look at 23 to scale the value. The value gets scaled correctly but it never updates again. Some other values in the same scheme is working, but the scaled value is frozen.
    Also in the communicator screen the 23 gets changed to 203.

    in reply to: arduino #3483
    Pieter
    Participant
Viewing 15 posts - 1 through 15 (of 16 total)