Server is unavailable

Forum Home Forums Installation Issues SCADA-Web Installation Server is unavailable

Tagged: 

This topic contains 14 replies, has 2 voices, and was last updated by Mikhail Mikhail 1 week, 6 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #2841

    LPG57
    Participant

    Hello,

    After migrating to Scada 5.4.1, I can’t log in on the Scada web page, get the message “Server is unavailable”.

    I used the same user as I used with the old version (admin).

    ScadaserverSVC log:
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> ScadaServerService 5.1.0.2 is started
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Check the existence of the data directories is completed successfully
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Check the existence of the configuration database files is completed successfully
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Input channels are read from the configuration database. Active channel count: 43
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Ouput channels are read from the configuration database
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Users are read from the configuration database
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Formulas are read from the configuration database
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> The formulas source code has been compiled
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Connection listener is started
    2017-11-22 22:21:50 <SERVER7><SYSTEM><ACT> Start server
    2017-11-22 22:21:51 <SERVER7><SYSTEM><ACT> Current data are loaded
    2017-11-22 22:21:51 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 22:21:51 <SERVER7><SYSTEM><ACT> The user ScadaComm is successfully authenticated
    2017-11-22 22:22:03 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 22:22:03 <SERVER7><SYSTEM><ACT> The user ScadaComm is successfully authenticated
    2017-11-22 22:22:30 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 22:22:30 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-22 22:42:25 <SERVER7><SYSTEM><ACT> Disconnect client 127.0.0.1
    2017-11-22 22:48:37 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 22:48:37 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-22 22:48:37 <SERVER7><SYSTEM><ACT> Disconnect client 127.0.0.1
    2017-11-22 22:49:04 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 22:49:04 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-22 23:09:08 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 23:09:08 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-22 23:09:08 <SERVER7><SYSTEM><ACT> Disconnect client 127.0.0.1
    2017-11-22 23:09:22 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-22 23:09:22 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-22 23:09:22 <SERVER7><SYSTEM><ACT> Disconnect client 127.0.0.1
    2017-11-24 18:25:00 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-24 18:25:00 <SERVER7><SYSTEM><ACT> Unsuccessful attempt to authenticate the user
    2017-11-24 18:25:00 <SERVER7><SYSTEM><ACT> Disconnect client 127.0.0.1

    ScadaServerSvc.txt:
    SCADA-Server
    ————
    Started : 22/11/2017 22:21:50
    Execution time : 1.20:12:49
    State : normal
    Version : 5.1.0.2

    Connected Clients (1)
    ———————
    1. 127.0.0.1; ScadaComm (Application); activity: 18:34:39

    ScadaWeb.log
    2017-11-22 23:09:08 <SERVER7><DefaultAppPool><ACT> User information has been added. IP address: ::1. Session: 54ao1isfna1zamq3si5xtkqo
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><ACT> Connect to SCADA-Server “localhost”
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><ERR> User name or password is incorrect
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><ACT> Disconnect from SCADA-Server
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><EXC> Error refreshing the tables of the configuration database:
    Scada.ScadaException: Unable to receive the configuration database modification time.
    at Scada.Client.DataCache.RefreshBaseTables()
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><ERR> Unable to connect to SCADA-Server. Try again.
    2017-11-22 23:09:22 <SERVER7><DefaultAppPool><ERR> Unsuccessful login attempt: peder – Server is unavailable. IP address: ::1
    2017-11-22 23:29:22 <SERVER7><DefaultAppPool><ACT> User information has been removed. IP address: ::1. Session: 54ao1isfna1zamq3si5xtkqo
    2017-11-24 18:25:00 <SERVER7><DefaultAppPool><ACT> Connect to SCADA-Server “localhost”
    2017-11-24 18:25:00 <SERVER7><DefaultAppPool><ERR> User name or password is incorrect
    2017-11-24 18:25:00 <SERVER7><DefaultAppPool><ACT> Disconnect from SCADA-Server
    2017-11-24 18:25:00 <SERVER7><DefaultAppPool><EXC> Error refreshing the tables of the configuration database:
    Scada.ScadaException: Unable to receive the configuration database modification time.
    at Scada.Client.DataCache.RefreshBaseTables()
    2017-11-24 18:25:00 <SERVER7><DefaultAppPool><ACT> User information has been added. IP address: 83.142.103.76. Session: lxw0v20243tol44phkjh34ul
    2017-11-24 18:25:10 <SERVER7><DefaultAppPool><ERR> Unable to connect to SCADA-Server. Try again.
    2017-11-24 18:25:10 <SERVER7><DefaultAppPool><EXC> Error refreshing the tables of the configuration database:
    Scada.ScadaException: Unable to receive the configuration database modification time.
    at Scada.Client.DataCache.RefreshBaseTables()
    2017-11-24 18:25:10 <SERVER7><DefaultAppPool><ERR> Unable to connect to SCADA-Server. Try again.
    2017-11-24 18:25:10 <SERVER7><DefaultAppPool><ERR> Unsuccessful login attempt: admin – Server is unavailable. IP address: 83.142.103.76

    #2842
    Mikhail
    Mikhail
    Moderator

    Hi,

    Please open C:\SCADA\ScadaWeb\config\WebSettings.xml in a text editor and check CommSettings section. These are the connection parameters for the web app. Can you provide them here?

    #2843
    Mikhail
    Mikhail
    Moderator

    Also check CPU load of ScadaServerSvc.exe.

    #2844

    LPG57
    Participant

    Hello Mikhail,

    The CPU load of ScadaServerSvc.exe is currently 0
    and here is the WebSettings.xml:

    <?xml version=”1.0″ encoding=”utf-8″ ?>
    – <WebSettings>
    <Param name=”SrezRefrFreq” value=”5″ descr=”Values refresh frequency, sec” />
    <Param name=”EventRefrFreq” value=”5″ descr=”Events refresh frequency, sec” />
    <Param name=”EventCnt” value=”50″ descr=”Display events count” />
    <Param name=”EventFltr” value=”true” descr=”Set ‘View’ events filter by default” />
    <Param name=”DiagBreak” value=”90″ descr=”Distance between points on the diagramm to make a break, sec” />
    <Param name=”CmdEnabled” value=”true” descr=”Enable commands” />
    <Param name=”SimpleCmd” value=”false” descr=”Simple commands sending” />
    <Param name=”RemEnabled” value=”false” descr=”Enable to remember logged on user” />
    </WebSettings>

    #2845

    LPG57
    Participant

    and here is the CommSettings.xml

    <?xml version=”1.0″ encoding=”utf-8″ ?>
    – <CommSettings>
    <Param name=”ServerHost” value=”localhost” descr=”SCADA-Server host or IP address” />
    <Param name=”ServerPort” value=”10000″ descr=”SCADA-Server TCP port number” />
    <Param name=”ServerUser” value=”ScadaWeb” descr=”User name for the connection” />
    <Param name=”ServerPwd” value=”12345″ descr=”User password for the connection” />
    <Param name=”ServerTimeout” value=”10000″ descr=”Response timeout, ms” />
    </CommSettings>

    I tried also with user “ScadaWeb”, but the result was the same

    #2849
    Mikhail
    Mikhail
    Moderator

    The format of the WebSettings.xml file was changed. You should take the new one from the distributive.
    You don’t need CommSettings.xml for the web app no more.

    #2856

    LPG57
    Participant

    Following the instructions above solved the login problem – thanks’

    However, when logged in the following message appear:
    “The requested view does not exist or you have insufficient rights to access it.”

    I can open the tables in the table editor.

    #2857

    LPG57
    Participant

    I solved the issue above, found out that there were differences in the Interface table between the old and new version.

    Now I only wonders how the “Rights” table “Interface Objects” field is populated? In the drop down list, there is only the demo objects, not the tables I built?

    #2858

    LPG57
    Participant

    Mikhail

    The issue with the rights table is solve, but now I have a new problem:

    When connecting with the web station, it works OK while doing it directly on the server itself, but when doing it from a PC outside the domain, I can login, but the tables are not updated with data and the message “Error updating current data” appear. After 10 secs, I’m thrown out.

    Login performed 10:21 was on localhost and succeeded, login performed 10:23 was from a remote PC and failed.

    ScadaWeb.log
    2017-11-27 10:21:54 <SERVER7><DefaultAppPool><ACT> Request SCADA-Server state
    2017-11-27 10:21:54 <SERVER7><DefaultAppPool><ACT> Disconnect from SCADA-Server
    2017-11-27 10:21:54 <SERVER7><DefaultAppPool><ACT> Connect to SCADA-Server “localhost”
    2017-11-27 10:21:54 <SERVER7><DefaultAppPool><ACT> User information has been added. IP address: ::1. Session: b3knixrzaedaicjuaoku3wml
    2017-11-27 10:21:57 <SERVER7><DefaultAppPool><ACT> Login: admin (Administrator). IP address: ::1
    2017-11-27 10:21:57 <SERVER7><DefaultAppPool><ACT> User information has been updated. IP address: ::1. Session: b3knixrzaedaicjuaoku3wml
    2017-11-27 10:22:27 <SERVER7><DefaultAppPool><ACT> Logout: admin. IP address: ::1
    2017-11-27 10:23:22 <SERVER7><DefaultAppPool><ACT> Request SCADA-Server state
    2017-11-27 10:23:22 <SERVER7><DefaultAppPool><ACT> Login: admin (Administrator). IP address: 199.64.75.186
    2017-11-27 10:23:22 <SERVER7><DefaultAppPool><ACT> User information has been updated. IP address: 199.64.75.186. Session: lxw0v20243tol44phkjh34ul

    ScadaServerSvc.log
    2017-11-27 10:21:54 <SERVER7><SYSTEM><ACT> Connect to client 127.0.0.1
    2017-11-27 10:21:54 <SERVER7><SYSTEM><ACT> The user ScadaWeb is successfully authenticated
    2017-11-27 10:21:57 <SERVER7><SYSTEM><ACT> Check user admin name and password. Result: passed
    2017-11-27 10:23:22 <SERVER7><SYSTEM><ACT> Check user admin name and password. Result: passed

    #2860
    Mikhail
    Mikhail
    Moderator

    Hi,

    Does it work from another PC in the same network?
    Please press F12 in a browser and provide logs (or screenshots) from the Console and Network tabs.

    #2880

    LPG57
    Participant

    Hello,

    If I’m connect using http://servername7scada from another computer within the domain, it works OK. But if I’m from the same computer use the external https://domainname/scada, it doesn’t work.

    #2888
    Mikhail
    Mikhail
    Moderator

    Hi,
    If you need HTTPS, you have to do special settings on IIS. See this

    #2897

    LPG57
    Participant

    There was already a certificate for port 443 for this web site, so when creating another one, I couldn’t log on remotely anymore. (Running SBS 2011)

    #2898
    Mikhail
    Mikhail
    Moderator

    HTTPS is more tricky. To solve this issue, a remote connection is required – this is a commercial service.

    #2899
    Mikhail
    Mikhail
    Moderator

    Does https://localhost/ work?

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.