RPi as a TCP server, Local PC as a client

Forum Home Forums Rapid SCADA on Raspberry Pi RPi as a TCP server, Local PC as a client

This topic contains 13 replies, has 2 voices, and was last updated by Mikhail Mikhail 1 year, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1407

    MohanadOdema
    Participant

    Hello,

    I’m new to using Rapid SCADA. I installed the software on my local PC (which I want to act as TCP client) and I want it to communicate with a RPi (TCP server).

    The RPi and the local PC are connected together via an Ethernet cable and the RPi operates as a server correctly. However, I’m facing some issues when I want to activate the communication line.

    I added the required credentials on the Scada Administrator, changed the common parameters of the Scada Communicator to the ip and port addresses of the RPi server and edited the communication line parameters. Still, the communication line is not functioning and gives me “Error initializing communication channel: Slave behavior of the communication channel is not supprted by Device 34 “RPi”

    I haven’t edited the XML file yet so I used a template from your example for now. I feel like I’m missing something or I misconfigured something incorrectly.

    Help anyone ?

    #1408
    Mikhail
    Mikhail
    Moderator

    Hello,
    You have to change communication channel properties in Communicator and set Master behavior. Do you poll your devices from the PC and need to send collected data to RPi?

    #1411

    MohanadOdema
    Participant

    Yeah that did it the channel is now up and running. Thanks !

    I only have one device the RPi which I poll from and send data to it that don’t need to be collected though.

    #1412

    MohanadOdema
    Participant

    I have another question if you don’t mind.

    The RPi (TCP server) is connected to a servo motor and some relay switches. The Pi automates these equipment based on the values it has in some of its holding register addresses.

    The question is now the communication line is active and I can read from the holding register, how can I set values in some of the register’s addresses ?

    #1413
    Mikhail
    Mikhail
    Moderator

    You need sending commands to a device. First of all, try to send them manually.
    For automatic control you need this module.

    #1414

    MohanadOdema
    Participant

    I’m trying to send it manually but neither does the commands tab in the communication channel in the communicator nor the output channels in scada admin contain a field where I can identify the holding register address. How can I specify the register address to which I want to set my values ?

    #1417
    Mikhail
    Mikhail
    Moderator

    How can I specify the register address to which I want to set my values ?

    Use Modbus template editor.
    Try to send a command from the tab of Communicator. If it doesn’t work, post a piece of a communication line log with the description of the problem.

    #1422

    MohanadOdema
    Participant

    Yeah it is working now.

    Much gratitude for your time and effort.

    #1425
    Mikhail
    Mikhail
    Moderator

    🙂

    #1451

    MohanadOdema
    Participant

    Another Question if you don’t mind,

    I want to utilize the Scada Web service, first should I change the server to the ip of the RPi on which the Scada Server is set or should I leave it as it is ?

    Second: Do I need a specific port number or leave it at 10000 ?

    I tried setting server to localhost and port number to 10000 and then I tried http://localhost/Scada and it gave 404 error. I also tried http://localhost/Scada:10000 and it gave me 403 forbidden access error.

    #1452
    Mikhail
    Mikhail
    Moderator

    I want to utilize the Scada Web service, first should I change the server to the ip of the RPi on which the Scada Server is set or should I leave it as it is ?

    If the web app work on another computer than Server, you must set the IP of the server in the web app settings.

    Second: Do I need a specific port number or leave it at 10000 ?

    Do not mix up the port of web server which is 80 by default and the port of Server app which is 10000 by default. You can change both of them, but you should understand that they are the different things.

    #1456

    MohanadOdema
    Participant

    Just to make sure you completely understand my design, the Scada TCP server is on the RPi while the Scada TCP client on which I want to implement my web server is a local PC connected to the TCP server by Ethernet cable.

    if my understanding is correct, I left the Server as localhost and port 10000. I added the sets and views as instructed in your documentation. However, when I type in the URL http://localhost/Scada, it gave me 404 error “Not Found The requested URL /Scada was not found on this server.

    Did I miss something ?

    #1458

    MohanadOdema
    Participant

    Thanks Nevermind I worked the ScadaWeb Server at last!

    However I still have a problem in the Scada Communicator. The channels are not bound to their device tags even though I created the required channels in the Scada Admin with the appropriate signals to match those in the template of my device in the ScadaComm.

    What can be the cause of this problem ??

    #1460
    Mikhail
    Mikhail
    Moderator

    You should create a new topic on Understanding the Software subforum. There is no RPi specifics.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.