Any questions about Rapid SCADA and Raspberry Pi

Forum Home Forums Rapid SCADA on Raspberry Pi Any questions about Rapid SCADA and Raspberry Pi

Tagged: 

This topic contains 55 replies, has 8 voices, and was last updated by Mistral Mistral 1 week ago.

Viewing 15 posts - 16 through 30 (of 56 total)
  • Author
    Posts
  • #414

    ASA
    Participant

    Ok

    How do you configure it ?
    Is it with windows then copy across if so what files?

    asa

    #415
    Mikhail
    Mikhail
    Moderator

    Hi,

    You definitely right.
    After configuring using Windows you should copy the content of the follownig folders:
    C:\SCADA\BaseDAT
    C:\SCADA\Interface
    C:\SCADA\ScadaComm\Config

    #428

    ASA
    Participant

    Ok the transferring of the files worked my next problem
    I have lost connection to my device (rs232) I am useing a usb to rs232 converter the rpi says it’s device ttyUSB0 what am I doing wrong?

    Asa

    #430
    Mikhail
    Mikhail
    Moderator

    Is the port successfully opened by SCADA-Communicator?

    #433

    ASA
    Participant

    According to the logs com1 to com9 all had the same
    Error

    Error opening serial port no such file or directory

    #436
    Mikhail
    Mikhail
    Moderator

    Specified port name is wrong. What is the full name of ttyUSB0 is listed by Raspberry Pi?

    #437

    ASA
    Participant

    Ok how do you get that?

    #438
    Mikhail
    Mikhail
    Moderator

    ls /dev/tty*

    #439
    Mikhail
    Mikhail
    Moderator

    Use should use /dev/ttyUSB0

    #440

    ASA
    Participant

    It is listed on the list as /dev/ttyUSB0

    Asa

    #441

    ASA
    Participant

    We’re should we use it?

    #442

    ASA
    Participant

    Are you able to send a example com config page?

    #444
    Mikhail
    Mikhail
    Moderator

    It is here

    #446

    ASA
    Participant

    First off thank you for your help to date!

    I have the usb sending commands to my plc

    My new problem it’s the wrong ones on windows the scada send out 64 04 70 07 00 16 D3 30 this works
    On pi it’s 64 04 B0 10 90 71 07 FE for some reason it’s changed I have checked the scadacomm config files and they appear to be the same what’s your thoughts

    Asa

    #447
    Mikhail
    Mikhail
    Moderator

    Hi,
    Please send a larger piece of the communication log.

Viewing 15 posts - 16 through 30 (of 56 total)

You must be logged in to reply to this topic.